2

How do I change the cpufreq policy range?

$ cpupower frequency-info
analyzing CPU 0:
  driver: powernow-k8
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0 1
  maximum transition latency: 109 us
  hardware limits: 800 MHz - 2.00 GHz
  available frequency steps:  2.00 GHz, 1.80 GHz, 1.60 GHz, 800 MHz
  available cpufreq governors: conservative ondemand userspace powersave performance schedutil
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 800 MHz (asserted by call to kernel)
  boost state support:
    Supported: no
    Active: no

You can see that hardware limit is at 2GHz, but policy limit is at 800. Trying

$ sudo cpupower frequency-set --max 2000000 
Setting cpu: 0
Setting cpu: 1

but without effect:

$ cpupower frequency-info --policy
analyzing CPU 0:
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.

I've tried echoing the values directly:

echo 2000000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

no dice.

The issue happens on xubuntu 17.04 x86_64 and on latest Majnaro i686, so I don't believe it's distro specific.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.