0

I have been using Linux gsync, as described below, by creating the jobs in OSX (local dir to S3) and then exporting the tix file out. That more-or-less seemed to work.

HOWEVER--- The gsync on Linux log is showing a message that it can't mark timestamps on the S3 side. As a result, every backup that runs is overwriting every file again with the message "An older version is overwriting a newer version"

QUESTION--- Ie there a linux switch command to tell gsync to ignore the timestamp and only use file sizes. Or simply ignore overwriting the file if the file exists. Or another solution :D

I.e.

gsync job-update /?=ignore-time

or something.

0

From Goodsync support(after two weeks):

William replied (2017/06/14 08:41 am EDT)   
there is no such option.

you should use only GS to sync to S3, then it stores good file mod time in state file and it can handle time translation.

So, basically, gsync on linux doesn't 'really' support S3. While it WILL copy the files out to S3, it can't recognize if a file to be copied is the same as the file that already exists in the S3.

So, if you set a directory to sync to S3, it will copy the entire directory to S3 - every time.

Maybe they'll do something about that someday :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.