Having applied this command by mistake:

sudo chown -R root:root /* 

Instead of applying the current folder as

sudo chown -R root:root ./*

Everything is root. My system is out of control. Linux doesn't accept my password. My distribution is Manjaro Linux (Arch based). Unluckily there is not any option to access root terminal from Grub as Ubuntu. Is there any way to fix this?

  • 1
    You can access the shell from Grub. When the grub menu appears, select the kernel line and type e to edit. At the end of the line append init=/bin/bash. Ctrl-X to boot. You will likely have to remount / as read-write. mount -n -o remount,rw /. But even with that, you have quite a mess to deal with.
    – Deathgrip
    Jun 14, 2017 at 7:11
  • 3
    You'll probably have to restore from backups, or reinstall the system.
    – dr_
    Jun 14, 2017 at 7:12
  • I backed up my system to its hard drive. Unfortunately copy paste didn't work. After rebooting desktop environment freezes too. I tryed to access shell with Grub yesterday. I typed init=/bin/sh it didn't work. As soon as i turn back home i will try this. I talked with Manjaro irc group someone said try your chance with live cd i will also try to change user permissions and password with it. Thanks.
    – Edip Ahmet
    Jun 14, 2017 at 7:50

1 Answer 1


Start your computer from Live version of Linux (USB/CD), chroot to crasched system and try reinstall all packages - have a look on this topic: https://bbs.archlinux.org/viewtopic.php?id=34832 how you can do it.


  • Thank you very much! It worked. first I booted with live cd and opened terminal as root, chroot ./media/.../* then sudo chown -R edip:edip ./* System works now :) Just su doesn't work, I will look for a way to restore root.
    – Edip Ahmet
    Jun 23, 2017 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .