0

I installed Fedora 25 as dual boot next to Windows 7. I have Turkish layout keyboard. And OS is in Turkish also. All the other buttons work and write normally, but buttons " i, ı, alt gr" dont function at all. These buttons work normally on Windows 7.

output of setxkbmap -print

xkb_keymap { xkb_keycodes { include "evdev+aliases(qwerty)" }; xkb_types { include "complete" }; xkb_compat { include "complete" }; xkb_symbols { include "pc+us+inet(evdev)" }; xkb_geometry { include "pc(pc105)" }; };

and when I run xev as normal user and type characters, everything works normally.

evtest did not work in root user.

And I noticed that , when I type on terminal everything is ok.

  • Did you set up the same keyboard layout as in windows? – Jakuje Jun 14 '17 at 6:22
  • Please edit question with output of the following: 1) setxkbmap -print. 2) run evtest as root, select keyboard, press buttons that don't work 3) the same with xev, as normal user (make sure you have focus and can see output for other keys). – dirkt Jun 14 '17 at 7:43
  • @dirkt I edited. – Şansal Birbaş Jun 15 '17 at 5:33
  • What do you have under "Input Sources" in "Region & Language" in the settings panel? (Sorry, I don't know what that is in Turkish....) – mattdm Jun 15 '17 at 14:54
1

I run setxkbmap tr and It got fixed.

  • This will not persist after a reboot. – Sethos II Jun 15 '17 at 5:53
  • I created a $HOME/.profile file and added this "setxkbmap tr" command inside it. – Şansal Birbaş Jun 15 '17 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.