1

I installed phpMyAdmin on my Arch Linux box. I then created a sym link named phpmyadmin in my /usr/share/nginx/html/ to /usr/share/webapps/phpMyAdmin/. When I visit http://127.0.0.1:8080/phpmyadmin/ in my browser I get 500 Internal server error. Checking in my nginx error log this' what I find:

2017/06/13 19:10:42 [error] 4059#4059: *1 FastCGI sent in stderr: "PHP message: PHP Fatal error:  session_start(): Failed to initialize storage module: files (path: ) in /usr/share/webapps/phpMyAdmin/libraries/session.inc.php on line 121" while reading response header from upstream, client: 127.0.0.1, server: localhost, request: "GET /phpmyadmin/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm/php-fpm.sock:", host: "127.0.0.1:8080"

Please how do I solve this error? How do I get my phpMyAdmin working? If you need my nginx.conf or php.ini let me know. Thanks.

  • session_start(): Failed to initialize storage module: files (path: ) sounds like your PHP is misconfigured (or not configured). What are your session settings in php.ini? – derobert Jun 13 '17 at 14:54
  • @derobert please have a look at the session block of my php.ini here pastebin.com/5V9kWhbf – Kha Kali Jun 13 '17 at 15:08
  • Does un-commenting the session.save_path setting help? Weird that the default would be blank, though. – derobert Jun 13 '17 at 15:12
  • I uncommented the line and provided a subdirectories integer and a path as directed. like so session.save_path = "3;/tmp" and restarted nginx. I still get the same error in the nginx error log. – Kha Kali Jun 13 '17 at 15:19
  • ☹ Not sure what's going on then. I suggest editing your question to include those details, and hopefully someone with more knowledge of PHP on Arch will take a look. – derobert Jun 13 '17 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.