1

I'm using KDE on Debian Stretch, and Ark is installed by default (version 16.08.3). I find it really convenient and easy to use. However, I cannot find a way to create a 7-zip archive without compression. To be clear, what would be the equivalent of specifing the "-mx=0" argument in the command line. I'm aware of the presence of the compression slider, but setting it to the minimum (all to left), still compresses the archive (I'd say that is the equivalent of "-mx=1"). Is there a way to accomplish 0 compression using Ark? If not, is there another likewise powerful archive manager (better if Qt-based) that allows to do so? I'd really prefer to stick with Ark if possible.

I've tried to manually change a line of code and rebuild Ark from source, just to test if hardcoding the "-mx=0" parameter into the source does produce some result. I've changed this:

enter image description here

to this:

enter image description here

in the file at path ark-16.08.3/plugins/cli7zplugin/cliplugin.cpp.

I don't know if that is something "clever" or I'm completely wrong, however that change doesn't produce any difference. Testing the original version available through apt and the one I've built from source on the same file, the outputted .7z archives are of identical size (about 50% of the original file, which surely isn't a not-compressed archive). Of course I've tried a simple

7z a -mx=0 archive.7z myFile

and it has produced a file of more or less the exact size of the original file, and of course in MUCH less time. I'm starting to think I have to surrender and using the CLI version.

  • What features of 7z are you using? If you don't care about any of them, you might just use the tar format. (I know this doesn't answer your question, but just a thought.) – Nemo Jun 27 '17 at 9:51
  • Thanks for your comment. I need to create password encrypted but not compressed archives. So I could use something like a .tar.cpt or something similar, but that needs two steps for encryption and two steps again for decryption, and Ccrypt as far as I know doesn't use multithreading. Furthermore, decrypting it on another PC wouldn't be as immediate as with a .7z, especially on Windows, where 7-zip archives are easily handled. – mars Jul 4 '17 at 15:23
  • Understood. I use 7z a -mx=0 -p too sometimes, so I'm curious about the answer too now. – Nemo Jul 6 '17 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.