2

I am using Openbsd 6.1/amd64 here.

Suddenly, I am no longer able to update or install a package.

When trying to do a

pkg_add vlc 

I am greeted with the message:

https://ftp.OpenBSD.org/pub/OpenBSD/6.1/packages-stable/amd64/: ftp: SSL write error: ocsp verify failed: ocsp response not current
https://ftp.OpenBSD.org/pub/OpenBSD/6.1/packages-stable/amd64/: ftp: SSL write error: ocsp verify failed: ocsp response not current
https://ftp.OpenBSD.org/pub/OpenBSD/6.1/packages-stable/amd64/: empty

I already ran pkg_add -uU, and pkg_check however, still the same errors.

Have you a suggestion?

6

This is likely a temporary issue, I can reproduce it. The mirror that I'm using, https://ftp.eu.openbsd.org/pub/OpenBSD, works as expected.

Someone reported this to the openbsd-misc mailing list. A response says:

It's a server-side problem, same on www.openbsd.org. Not visible in normal graphical browsers because they fallback to the CA's OCSP server whereas ftp(1) just relies on the stapled cert.

Simplest workaround is to use a mirror, [...]

It will likely be resolved within a day or two (my guess). In the meanwhile, use one of the many mirror sites.


UPDATE (the day after): The issue has now been resolved on the affected servers.


Note that -U is never needed when you run pkg_add -u. It's only when you install a new package that -U will update any outdated packages that the new package depends on. With pkg_add -u you update all packages.

6

I just wanted to add that you will get the same error message if your system time is off. I got the same error, tried using a mirror as Kusalananda suggested but still had SSL errors. I checked the system time, and it was about two weeks behind. Running ntpd -s fixed the issue and pkg_add worked again.

  • 1
    It was not my case, however thanks for the feedback. Maybe it is useful for someone else. – Rui F Ribeiro Oct 3 '17 at 12:36
  • To enable ntpd (sync time) edit /etc/rc.conf. Find line with ntpd_flags and replace it with ntpd_flags="-s". It resolved my issue with "pkg_add" - date was 2 days behind in restored virtual machine – izy Oct 24 '18 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.