0

i have this hardware piece:

enter image description here

it called: airfiber x5

this device can be accessed through SSH using putty program or WinSCP to view its operating system's files

it has an embedded web interface,

however i found the directory of its web interface in: /usr/www

i am trying to change the index.cgi of the page, more specifically, i want to add my company's logo next to the manufacturer's logo to the web interface,

the problem is i cannot edit anything in the www or outside of it.

it kept saying in putty: rm: cannot remove 'index.cgi': Read-only file system

or i am trying to modify link.cgi file using WinSCP by overwriting with another file.

it says: scp: /usr/www/160311.1301/link.cgi: Read-only file system

i even tried in putty to give permissions using chmod or chown

chmod: index.cgi: Read-only file system
chown: index.cgi: Read-only file system

i tried these solutions: https://askubuntu.com/questions/47538/how-to-make-read-only-file-system-writable

https://askubuntu.com/questions/572579/chmod-error-changing-permission-read-only-file-system

none of them worked.

what i am thinking is, is there a hardware protection for these types of devices?

or there is something i am missing?

Notice: the internet interface configures the Device's settings, so there has to be a place where it stores data, and that data is changeable,

my question is: how it is done!, some areas in the OS are protected and some of them are not!

how all the files can be unlocked !

enter image description here

i typed the command: uname -a

to get all system info.

AF06.v3.2.1# uname -a Linux UBNT 2.6.33 #1 Fri Mar 11 13:02:34 CST 2016 armv5tejl unknown

if anybody have an idea or a theory of how these hardwared linux work

EDIT: i typed: mount

AF06.v3.2.1# mount
rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro,relatime)
none on /proc type proc (rw,relatime)
none on /sys type sysfs (rw,relatime)
tmpfs on /var type tmpfs (rw,relatime,size=32768k)
dev on /dev type tmpfs (rw,relatime)
none on /dev/pts type devpts (rw,relatime,mode=600)

and i typed: cat /proc/mtd

AF06.v3.2.1# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00010000 "UBL"
mtd1: 00040000 00010000 "u-boot"
mtd2: 00010000 00010000 "u-boot-env"
mtd3: 00200000 00010000 "kernel"
mtd4: 00950000 00010000 "rootfs"
mtd5: 00400000 00010000 "u-code"
mtd6: 00040000 00010000 "cfg"
mtd7: 00010000 00010000 "EEPROM"
  • Embedded devices are often very non-standard. – Stephen Rauch Jun 11 '17 at 20:34
  • First, you have to find out, how what parts of the file system are mounted. What does mount say? Typically there will be a way to mount then writable as developers of the system need then writable during development and debugging, but they sometimes make it hard to figure out. – Philippos Jun 12 '17 at 4:43
  • Embedded devices often have read-only filesystems; sometimes they have an overlay filesystem which allow you to make changes, but only in some subdirectory trees. Look at mount, cat /proc/mtd etc. – dirkt Jun 12 '17 at 9:49
  • i typed: mount and cat /proc/mtd please check the edit part in the question – Tarık Seyceri Jun 12 '17 at 18:24
  • mr @Philippos i did as you told me, can you please tell me what to do next ? – Tarık Seyceri Jun 14 '17 at 15:15
2

squashfs is a read-only file system you cannot remount it writable cauz it's a compressed file-system.

  • What can be done to fix this issue ? – Tarık Seyceri Jun 12 '17 at 18:48
0

This line

/dev/root on / type squashfs (ro,relatime)

says your filesystem is mounted read-only (ro). All the other mounts are temporary (not "real" filesystems). There is no overlay mount.

This means you can't change anything on your filesystem.

The only thing you can do is to get a copy of the firmware (or extract it), change it on some other PC to the way you want it to look like, and uploaded the changed firmware it using u-boot.

To try out the changes, it may be possible to temporarily mount some other devices, maybe over the network, depending on what the installed kernel and the hardware supports.

All in all, it's a lot of effort to just add a company logo, and you'll still have to invest a lot of time to make it work if this is your first time looking at embedded devices. And no, I can't give a step-by-step instruction, it really depends on what exactly is on the device.

  • Okay, fair enough, your explanation and your ideas are perfect, thank you very much, the good thing here that i can teach my self :) , and i don't give up easily.., as long as Google is online ;) – Tarık Seyceri Jun 15 '17 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.