-1

So I am new in Kali Linux and want to learn the basics. I bought a TP-Link dual boot USB adapter. I can see the device when I type iwconfig wlan0. I can run it on monitor mode also. It works fine. But when I type airodump-ng wlan0 it doesn't give me any errors however it doesn't show any networks either. So I did some research and tried the stuff I found online such as airodump-ng mon0 but when I run the command it gives me an error such as `no such device'. What should I do to see the networks around me? Is there a problem with my wireless card? Please help. And thanks for reading.

I think the guy in the video has the same problem. https://www.youtube.com/watch?v=jpzZe7PO8TY

1

You have to use the following codes

airmon-ng start wlan0

Depending on the version of Kali your monitor mode will be either wlan0mon for newer versions or mon0 for older versions. Since you do not get any output on using mon0, use

airodump-ng wlan0mon

You can find the name of the monitor mode using ifconfig after using airmon-ng. It will specify the new network interface. The person in the video made the same mistake as he was specifying mon0 instead of wlan0mon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.