0

So here's the story:

Running Windows Server in QEMU with basically default options on Ubuntu results in horrible upload speeds for whatever reason (you can see this when running Google's speed test, or any other different kind of speed test which isn't your usual Flash-based). These are the command line options I am using:

-net nic -net user,hostfwd=tcp::3389-:3389

However, the way Proxmox runs QEMU results in better speeds because it is using a "bridge". I don't fully understand how it works, but I know the key lies in the /etc/network/interfaces configuration.

How do I make and use a bridge in QEMU to provide my VM internet access with Ubuntu 14.04?

I only plan to forward a handful of ports to the VM, including RDP (3389) of course. I am using an OVH dedi, so it has IPv6 and IPv4 on eth0.

1 Answer 1

0

Well, the closest I got actually solves my original question, but creates a fresh set of new problems. Creating a VM like so should automatically create the bridge:

virt-install --connect qemu:///system \
  --name ws2016 --ram 2048 --vcpus 4 \
  --network network=default,model=virtio \
  --disk path=/dev/sda2,size=69 \
  --graphics vnc,listen=0.0.0.0 \
  --cdrom /media/YourWindowsISO.iso \
  --disk path=/media/virtio-win.iso,device=cdrom \
  --os-variant win2k8 --video cirrus

After using this, editing libvirt to specify the CPU type (so Windows doesn't freeze on setup), enabling VNC binding in qemu.conf, and installing Virtio drivers on the Windows guest, it works-

Until you reboot the host.

From then on the system gets bricked, refuses all incoming connections including SSH, so RIP goes your remote dedi.

Settled for simply using QEMU in a screen, default networking settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.