2

I want to build an elementary os bluetooth github project on elementary os. When I run

cmake -DCMAKE_INSTALL_PREFIX=/usr ..

it starts and checks some things. Then error: No package 'libnotify' found. This appears to be some kind of developer package.

How do I install this for elementary os?

2

On elementary OS and other Debian-based distributions such as Ubuntu and Linux Mint, the package is libnotify-dev. Generally, to compile a program that uses the XXX library, you need the package called libXXX-dev.

You could start a terminal, log in as root (or, in case there is no root account, use sudo -s), and run:

apt-get update
apt-get install -y libnotify-dev

But there are other ways to install a package, as well.

  • for elementary os, sudo works fine – P.Brian.Mackey Jun 10 '17 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.