2

Hello I'm running Kali Linux on VirtualBox. I'm attempting to run a Bridged Adapter connection. Relevant details:

(In VM) Name: Kali Operating System: Ubuntu (64-bit)

Adapter 1: Intel PRO/1000 MT Desktop, (Bridged Adapter, Microsoft Network Adapter, Multiplexor Driver)

(Host machine) Host Machine (Windows 10) Wireless adapter: Intel (R) Dual Band Wireless AC-3165

I'm following a tutorial as well as tinkering around after reading various tutorials online. What I have done so far:

  • Selected 'Bridged Adapter' from the dropdown in network settings in VM
  • Selected 'Allow VMs' from 'Promiscuous Mode:' in VM settings.
  • Checked 'Cable Connected' in VM settings.
  • Created a bridge in Windows network settings between my Windows Wireless adapter and the VM adapter. It has created 'Microsoft Network Adapter Multiplexor Driver' in Windows Network Settings.
  • I've selected Microsoft Network Adapter Multiplexor Driver in network settings in VM.
  • In Kali I have changed managed=false to managed=true in NetworkManager.conf as per instructions in tutorial.

And according to various sources it should be as simple as that. When I ping a well known domain to test, it hangs for a few seconds and I get 'Name or service not known'. I've been messing around with this for some time with no success. Does anyone have any ideas. Any help much appreciated.

1 Answer 1

3

Why I see This?

You see this error when resolvconf file is altered or overwritten because this file is used to configure Dns server, I faced same problem and after banging my head for 1 week I found this as you can see that I was getting that "Name or service not known error"

SOlution

sudo apt-get purge resolvconf

you should see this

enter image description here

Finally

after running this command you need to restart your machine.

2
  • 1
    yes i tried this and it worked. thanks for that.
    – jonnjo2005
    Aug 5, 2019 at 10:00
  • I am very glad to help you @jonnjo2005 Aug 6, 2019 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .