0

I was trying to completely remove mono since it breaks my ability to apt-get upgrade.

When I try:

sudo apt-get upgrade

Then I get this error:

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libmono-i18n-cjk4.0-cil : Depends: mono-runtime (>= 5.0.0.100) but 4.8.0.495-0xamarin1 is installed
 libmono-i18n4.0-cil : Depends: mono-runtime (>= 5.0.0.100) but 4.8.0.495-0xamarin1 is installed
 libmono-system-configuration4.0-cil : Depends: mono-runtime (>= 5.0.0.100) but 4.8.0.495-0xamarin1 is installed
 libmono-system-web4.0-cil : Depends: mono-runtime (>= 5.0.0.100) but 4.8.0.495-0xamarin1 is installed
 libmono-system4.0-cil : Depends: mono-runtime (>= 5.0.0.100) but 4.8.0.495-0xamarin1 is installed
                         Recommends: ca-certificates-mono (= 5.0.0.100-0xamarin4+debian7b1) but 4.8.0.495-0xamarin1 is installed
E: Unmet dependencies. Try using -f.

When i try to remove any of the packages below via:

sudo dpkg -r libmono-i18n-cjk4.0-cil

Then i get this error:

dpkg: dependency problems prevent removal of libmono-i18n-cjk4.0-cil:
 libmono-i18n4.0-all depends on libmono-i18n-cjk4.0-cil (= 5.0.0.100-0xamarin4+debian7b1).

dpkg: error processing package libmono-i18n-cjk4.0-cil (--remove):
 dependency problems - not removing
Errors were encountered while processing:
 libmono-i18n-cjk4.0-cil
  • Have you tried removing the packages higher up the dependency tree? It looks like the meta-package for Mono on Debian-derived systems would be mono-devel or mono-complete. mono-project.com/download/#download-lin – bgvaughan Jun 8 '17 at 18:02
  • What does sudo apt-get dist-upgrade try to do? Or sudo apt-get remove libmono-i18n-cjk4.0-cil (etc.) – derobert Jun 8 '17 at 18:30
  • @bgvaughan, yes both of those packages removed succesfully – schmoopy Jun 8 '17 at 18:48
  • @derobert both of those commands gives me the same error as dpkg – schmoopy Jun 8 '17 at 18:48
  • @schmoopy which command does—there were two. Also, I'm pretty sure apt-get can't print out 'dpkg: dependency…' so it gave a different error—but maybe saying the same thing? Can you remove libmono-i18n4.0-all? Normally apt-get will chase up the chain for you... do you maybe have a held package? – derobert Jun 8 '17 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.