5

Is it possible to run one's own items from the Run box triggered by Alt+F2 in LXDE (ie lxpanelctl run)? For example, can I add shell scripts that I have created, so that they can be run from the Run box? If so, how can I do it?

I can run scripts I've created directly from a terminal and have them in a directory which has been added to $PATH but I don't know how to make them accessible via the Run box.

1

1 Answer 1

0

If they are in your $PATH, and executable they will show up in lxpanelctl run

That is to say they do for me when running LXDE on Ubuntu 16.04

5
  • 1
    Thanks for your answer, but it isn't enough for me. I assume the one I'm using as a test is correctly in $PATH and executable because I can enter its name directly in a terminal and it runs fine. Entering it in lxpanelctl run gives me a 'failed to execute child process'. I'm on Arch so maybe I should ask in their forum :)
    – Lee K-B
    Jun 20, 2017 at 2:36
  • yeah maybe. trying to think of LXDE-specific packages I might have that you do not. Issue with that is I was testing your issue on a VM that will be used to roll out some kiosk-type stations and I decided to use LXDE because it's so lightweight. I only installed lxde lxdm with the --no-install-recommends flag and I still get auto-completion. And this is having started with the ubuntu server iso (i.e. no desktop). Maybe the bash-completion package is stepping in to help out?
    – kadamwolfe
    Jun 21, 2017 at 3:52
  • ooh. it may be an issue on which dotfiles get sourced when you login. I was just dealing with this earlier with Linux Mint 18. When I login via GUI my .bashrc gets sourced, but from a terminal emulator it does not and it was causing issues with with my $PATH. It came down to the GUI using .profile while my terminal emulator using .bash_profile, one of which wasn't sourcing .bashrc
    – kadamwolfe
    Jun 21, 2017 at 3:59
  • Thanks for your further comments! I don't have .profile, and .bash_profile only has one line ([[ -f ~/.bashrc ]] && . ~/.bashrc). This problem has been solved here bbs.archlinux.org/viewtopic.php?pid=1720408 but not in a very satisfying way so I'll hold off on creating a new answer. If you understand how I should be doing this right (adding ~/bin to $PATH such that LXDM sources it) then by all means update your answer and I'll mark it as the solution.
    – Lee K-B
    Jun 25, 2017 at 8:42
  • For me, running PATH=~/.local/bin lxpanelctl run in a terminal still doesn't find executables in ~/.local/bin. Feb 5, 2019 at 19:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .