1

I have successfully installed Matlab 2011 on my Ubuntu Mate 17.04 machine. The installation directory is /home/matlab

For instance, my installation directory looks like (see image below) enter image description here

Now I read an article on Mathworks website that asks me to go to the bin directory and type matlab to open the application

The content of my bin directory looks like enter image description here

I typed

matlab

The terminal output is

/usr/bin/matlab: 1: /home/snow/matlab/bin/util/oscheck.sh: /lib/libc.so.6: not found
/home/snow/matlab/bin/glnx86/MATLAB: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

I tried other alternatives like

. matlab
bash matlab
./matlab

etc. but was not able to open the application.

Any help?

I have also given full permission (using chmod 777) to all files present in the bin directory.

7
  • There was no error throughout the installation process. it asked for the installation directory and it proceeded with it. Prior to this, there was an iso image that I mounted on /media/mathworks and then I simply followed the instructions given. I followed "in.mathworks.com/matlabcentral/answers/…"
    – Upendra01
    Jun 7 '17 at 12:41
  • Please add the output of file ~/matlab/bin/matlab and uname -a.
    – ChristophS
    Jun 7 '17 at 12:45
  • file ~/matlab/bin/matlab /home/snow/matlab/bin/matlab: POSIX shell script, ASCII text executable
    – Upendra01
    Jun 7 '17 at 13:04
  • uname -a Linux snow-Aspire-4738Z 4.10.0-21-generic #23-Ubuntu SMP Fri Apr 28 16:13:17 UTC 2017 i686 i686 i686 GNU/Linux
    – Upendra01
    Jun 7 '17 at 13:04
1

Basically, the error message is telling you a few files are missing (or else Matlab can't find them)....

/usr/bin/matlab: 1: /home/snow/matlab/bin/util/oscheck.sh: /lib/libc.so.6: not found
/home/snow/matlab/bin/glnx86/MATLAB: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

This means no matter what you do you won't be able to get the program to run without installing the necessary files or if the required packages are already installed but Matlab can't reference them you'll need to create the necessary symbolic links to them to allow the program to run. How this all works is largely dependent on your local installation and setup though hence the other person's question regarding your architecture. Read the following two links and things should become clearer to you...

https://www.mathworks.com/matlabcentral/answers/95976-why-do-i-get-a-libc-so-6-not-found-error-when-launching-matlab-in-ubuntu

https://askubuntu.com/questions/40416/why-is-lib-libc-so-6-missing

0
1

While MATLAB is distributed as a compiled binary it requires a bunch of poorly documented dependencies. Depending on how minimal your Mate install is, you may not have all the correct dependencies. I created a Matlab R2011b PKGBUILD for Arch which lists the dependencies for Arch. These include: libxmu, libxp, libxpm, libxrandr, and libxtst. the PKGBUILD might help you identify the missing packages and files.

1
  • I tried installing these packages but Ubuntu is not recognizing them altogether. It just says that the concerned package could not be located
    – Upendra01
    Jun 7 '17 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.