0

Try to install realm object server repository in centos server using oracle virtual box .

Here I am not able to install any repository because of mounting issue. enter image description here

2

Just download Centos ISO image form this index site http://ftp.heanet.ie/pub/centos/7/isos/x86_64/ and choose CentOS-7-x86_64-Everything-1611.iso which its size 7.7G(if you have it then skip this step).

then mount it to Virtualbox (double click on VB cdrom and browse to ISO location and choose it)

then create a file in /etc/yum.repo with name myrepo.repo

Like following steps:

vim /etc/yum.repos.d/myrepo.repo

type the following inside the file :-

[myRepo]

name=Cdrom Repository

baseurl=file:///cdrom

gpgcheck=0

enabled=1

save and exit it .

Then create mount point and mount cdrom to it :

mkdir /cdrom

mount /dev/cdrom /cdrom

Last thing disable the default Centos repository By adding enabled=0. Like Following :

vim /etc/yum.repo.d/Centos-Base

enter image description here

And now you have local repository in your machine(check it with yum repolist)

0

This is not an issue with CentOS, but your hypervisor.

Judging by the grayed out CD/DVD icon on the bottom of the VM window of Virtualbox, you do not actually have a CD/DVD attached to the VM. Right click that icon, attach your physical CD/DVD drive or an image, and then try to mount it again.


EDIT:

In relation to your comment and setting up a repository:

The repositories should be configured out of the box, if your VM can connect to the internet, then simply do so.

If your VM cannot connect to the internet, then you want to do the following:

  • download the image
  • attach it to the VM through Virtualbox
  • mount it at /mnt
  • create a file in /etc/yum.repos.d/ called whateveryouwant.repo

Put the following into the file

[LocalDVD]
name=Local Repository
baseurl=file:///mnt
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

Then do a yum clean all and yum update.

  • My cpu does not have any CD/DVD drive . I want to install repository .Is it possible without mounting ? – sradha Jun 7 '17 at 8:38
  • What were you trying to achieve with mounting the cdrom device on /mnt? Either way, you should have repositories already configured - see what they are with the yum repolist. If you have internet, then simply use those. – user6075516 Jun 7 '17 at 8:50
  • Actually I am trying to install realm object server which is not supported in windows , I tried yup repolist , but its returning me zero . Same way I tried in laptop after mounting its working fine , but in desktop I am not able to mount . – sradha Jun 7 '17 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.