1

I have a RedHat 6.5 on AWS EC2 running kernel 2.6.32.431, I have installed the ixgbevf driver with the minimum version the doc recommends. After configuration the system now has 2 queues(IRQs):

grep eth0-TxRx /proc/interrupts

48: 7986 0 0 0 0 0 0 0 PCI-MSI-edge eth0-TxRx-0

49: 7026 0 0 0 0 0 0 0 PCI-MSI-edge eth0-TxRx-1

However, even if the /proc/irq/48/smp_affinity or the /proc/irq/49/smp_affinity got changed to 4, there seems to be no any change. The output of "eth0-TxRx | /proc/interrupts" remains the same.

grep eth0-TxRx /proc/interrupts

48: 8025 0 0 0 0 0 0 0 PCI-MSI-edge eth0-TxRx-0

49: 7096 0 0 0 0 0 0 0 PCI-MSI-edge eth0-TxRx-1

The queues were still fixed to the CPU core 0.

I have been seeking the solution for a while, some of answers suggested that the Redhat 6.5 is lacking of XENFEAT_hvm_pirqs kernel feature with running kernel 2.6.32.431. But it could somehow be seen worked on RedHat 6.9:

grep Tx /proc/interrupts

48: 16 0 0 0 2810 0 0 0 PCI-MSI-edge eth0-TxRx-0

49: 22 2326 0 0 0 0 0 0 PCI-MSI-edge eth0-TxRx-1

Since if using XENFEAT_hvm_pirqs, the output should show xen-pirq-msi, but here RedHat 6.9 and RedHat 6.5 both display PCI-MSI-edge. I suppose they were both not using XENFEAT_hvm_pirqs flags here, were they?

Could anyone help figure out what exactly the kernel flag is? what is the purpose of XENFEAT_hvm_pirqs? Does this flag have anything to do with this problem? Is there any backport I could use to get this resolved?

By the way, the RedHat 6.5 was imported from Vmware, and it could work pretty well on Vmware. And the smp_affinity parameters could work as expected. Thanks very much in advance for any answers.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.