0

I have several problems, but here I will just focus on the current most important one.

I have Mint on an SSD that used to be in a laptop that had Win 7 installed on a separate SSD running as dual boot. The laptop broke and I used an old win 7 machine to try to boot into the Mint SSD. Unfortunately, the win SSD was still in it so grub got screwed.

Now I have a newer Win 7 machine that is used for music and video production. I thought I would be safe removing the Win 7 SSD from that machine and putting the Mint SSD in to try to fix grub. So I did and booted from a grub rescue disk. Grub rescue did it's thing and told me it was fixed. So I rebooted and my old grub complete with my own background image came up on the screen. However, when booting into Mint it would get so far and fail. That problem I will save for later!

I then removed the Mint SSD and put the Win 7 SSD disk back in and tried to boot. I was shocked to see an error message from grub saying the disk was missing! When I ran grub rescue for the Mint SSD I had left a storage drive in the machine and I think grub got installed/recovered to that and not the Mint SSD as intended. Disabling the storage HDD in the bios I tried booting into Win 7 again and now I get an error saying Reboot and select proper boot device or insert boot media in selected boot device and press a key The Win 7 SSD shows up in the bios and is selected as the boot device. I think grub (that got installed on the wrong (storage) drive), must have screwed up the win 7 boot loader now. How can I fix/reverse this? Why is the win 7 drive not booting?

  • Do you have MBR or GPT partitions structures? – Krzysztof Stasiak Jun 7 '17 at 8:14
0

to repair only windows bootloader i suggest to unplug other disk and you may boot from windows install disk and use in console:

repair mbr:

bootrec.exe /fixmbr
bootsect.exe /nt60 all /force /mbr

then find windows instalations dirs:

bootrec.exe /rebuildbcd
  • This didn't work. Before I did this, I ran gparted and set the flag to boot for this drive. Now I'm getting BOOTMGR missing error. Have tried all usual steps to fix that. – Ally Jun 8 '17 at 10:20
  • did bootrec find your windows instalation dir? – Krzysztof Stasiak Jun 8 '17 at 11:10
  • you may try: bootrec /RebuildBcd then bootrec /fixMbr then bootrec /fixboot – Krzysztof Stasiak Jun 8 '17 at 11:11
  • bootrec doesn't seem to find my win installation. I get something like: "windows installations 0". The win 7 dvd does find it though so it is there. Just can't boot it. So this did not work. – Ally Jun 10 '17 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.