3

When I am typing or viewing text on my terminal, the color is white. Any command after I type my prompt is white, and the default output (stdout) is white.

I looked and my terminal emulator does not have any direct controls for "default foreground color".

How can I change this color? This question only explains how to change it for certain programs and this question only answers for the "Terminator" program. I would like to set this as a default for all terminal emulators I am using.

For instance, if I end my PS1 variable with an ANSI color code, then what I initially type will have that color, however this does not carry over for other things output to stdout.

  • 1
    It does, though, carry over. However, it can very easily be overridden. For example, if your PS1 leaves the text as bright green, and your ls is colorized, then when you ls, that bright green will persist right up until the next color change. The only "work-around" for this is, like with the program-specific guides you already reference, to redefine what "non-bold white" looks like, as that is the default color. – DopeGhoti Jun 6 '17 at 23:20
  • I see. How would I redefine "non-bold-white"? – Startec Jun 6 '17 at 23:20
  • @Startec That is a terminal-specific option. Most terminal emulators have options to change these colors, but it is not something you can do in Bash itself – Fox Jun 7 '17 at 1:51
  • What is this terminal emulator? – Gilles Jun 7 '17 at 22:42
  • I use a few. Mosh for chrome and the Linux subsystem for windows are the two main ones. – Startec Jun 8 '17 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.