1

I can't connect to my wireless LAN with my usb wifi, via ifplugd or wpa_supplicant. My wpa_supplicant.conf content:

  ctrl_interface=/var/run/wpa_supplicant

  network={
  driver=wext
  ssid="myessid"
  scan_ssid=1
  proto=WPA
  pairwise=TKIP
  group=TKIP
  key_mgmt=WPA-PSK
  psk="mypassphrase"
 }

The command I use:

 wpa_supplicant -iwlan0 -Dwext -cwpa_supplicant

The output:

 Successfully initialized wpa_supplicant
 ioctl[SIOCSIWENCODEEXT]: Invalid argument
 ioctl[SIOCSIWENCODEEXT]: Invalid argument

At the same time, the iwevent wlan0 output is:

 Waiting for Wireless Events from interfaces...
 17:02:53.825711   wlan0    Set Mode:Managed
 17:02:53.826035   wlan0    Set ESSID:"g\xC6isQ\xFFJ\xEC)\xCD\xBA\xAB\xF2\xFB\xE3F|\xC2T\xF8\x1B\xE8\xE7\x8DvZ.c3\x9F\xC9\x9A"

Also, iwpriv wlan0 shows the following:

wlan0     Available private ioctls :
      ndis_reset       (8BF0) : set   0       & get   0      
      power_profile    (8BF1) : set   1 int   & get   0      
      deauthenticate   (8BF3) : set   0       & get   0      
      network_type     (8BF2) : set   1 char  & get   0      
      media_stream     (8BF4) : set   1 int   & get   0      
      reload_defaults  (8BF7) : set   0       & get   0 

I am using ndiswrapper.

My device:

 Bus 002 Device 002: ID 0457:0163 Silicon Integrated Systems Corp. 802.11 Wireless LAN Adapter

Ndiswrapper output:

 sis163u : driver installed
device (0457:0163) present

Ndiswrapper is loaded at startup by modprobe.

And my iwconfig output is:

 wlan0     IEEE 802.11g  ESSID:off/any  
      Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
      Bit Rate:54 Mb/s   Tx-Power:16 dBm   Sensitivity=0/3  
      RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off
      Link Quality:0  Signal level:0  Noise level:0
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

EDIT: I was doing it wrong. I should've used the -c parameter instead of -C. But unfortunately, the problem its essentially the same.

2

The output of your wpa_supplicant command ends with this:

You may have another wpa_supplicant process already running or the file was left by an unclean termination of wpa_supplicant in which case you will need to manually remove this file before starting wpa_supplicant again.

...which should be pretty obvious. You need to check whether there's already a wpa_supplicant running. Do so by way of:

pgrep wpa_supplicant

If that produces some output, then you need to kill the process ID that pgrep gave you. If it does not, then you need to clean up the file which wpa_supplicant tries to make.

If that doesn't fix it, then please post the output after having done the above (in your original post, not as a comment)

  • killall wpa_supplicant should solve the problem – GAD3R Jun 6 '17 at 15:18
  • 1
    In 99% of cases, yes. I try to accommodate for the 1% where that isn't sufficient as well... – Wouter Verhelst Jun 7 '17 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.