0

I'm running Ubuntu server 16.04 LTS and I'm trying to use internet through WiFi I already have a working internet connection with an ethernet cable on the same machine.

I'm running into a weird issue with my WiFi connection through the terminal I use the following command to connect to my WiFi network

sudo nmcli d wifi connect MYROUTERSSID password MYPASSWORD

I successfully connect to the wifi network

I then test to see if there is internet on the wireless interface by running the following command

ping -I wlx74da38839273 8.8.4.4

Now the problem

If I connect to my home wireless router I do get internet, but if I connect to any of my Android phones with tethering enabled, it does connect, but when I ping it I get 100% packet loss. I tried the Tethered connection on 3 different laptops running Windows and it works 100% fine. What are some the things to check for so I can troubleshoot this problem?

  • So the problem only occurs when connecting to your Android hot spots? What device is this? – Academiphile Jun 6 '17 at 4:50
  • I have tried this with the wireless router that the computer is also connected to with an Ethernet cable, which does work, but I do get some minor packet loss. I have tried with two phones a Samsung Galaxy Stellar and a HTC incredible. Same results with both phones. 100% packet loss – Arya Jun 6 '17 at 7:50
  • What kind of device is the computer? – Academiphile Jun 6 '17 at 10:15
  • It's a Lenovo Thinkcenter M92p with a Edimax EW-7811Un usb WiFi adaptor – Arya Jun 6 '17 at 17:32
  • I just tried on a ASUS D550CA-RS31 with identical results – Arya Jun 6 '17 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.