35

I dualboot Slackware64 and Windows 7.

The volume under Linux when maxed seems a lot lower than when it is maxed on Windows.

My soundcard chip is Realtek ALC662. Volume is set to 100% for PCM and Master in alsamixer and in whatever application I am playing sound with.

Is there anything further I can do to get the volume as loud as it is in Windows?

2
  • If you don't mind switching your player, vlc seems to be able to increase the volume tremendously... maybe other players can do that, too?
    – sr_
    Apr 20, 2012 at 8:27
  • 3
    @sr_ that isn't really a solution to me, since it can damage speakers and isn't application wide.
    – thx1139
    May 5, 2012 at 16:47

11 Answers 11

41

This is probably an issue with your ALSA sound level settings. There are two main volume settings: PCM and Master. Usually only one of them is controlled via desktop GUI settings (you can select which one that is in your audio settings).

If you run alsamixer in your terminal, check the volume levels for both of them. If you can't find the system setting to select the default volume control mechanism, try this:

  • open up alsamixer in your terminal
  • select the right sound card if you have more than one with F6
  • change the volume using your desktop controls and notice, which alsamixer setting is changed
  • in alsamixer, increase the level of the other volume control (i.e. If "PCM" was changed while you changed volume from the GUI, then increase "Master" in alsamixer).

Note: You exit alsamixer using the Esc key.

6
  • 3
    This is definitely not the case. PCM and Master are both set to 100%, as I mentioned in the question.
    – thx1139
    May 5, 2012 at 16:24
  • @thx1139 Sorry - I overlooked this. This could be some weird driver issue then... Or broken ALSA configuration. Could you add the output of lsmod | grep snd to your description? May 11, 2012 at 9:40
  • 1
    This worked for my Arctis 7 headset, press s to select the correct device first.
    – Celsiuss
    Apr 16, 2020 at 23:03
  • This worked wonders on ubuntu 20.04
    – m-ketan
    May 31, 2020 at 16:39
  • Ony my Ubuntu 18.04 there is no PCM listed and master is not modified by the volume keys.
    – lucidbrot
    Jul 19, 2020 at 13:24
10

The following worked for me:

  1. In Terminal, run alsamixer.
    • Note that only one volume control is visible, two if you include the microphone.
  2. Press F6 to switch to a different sound card.
  3. Switch from (default) to HDA Intel.
  4. A wide range of volume controls now appear, with Master being less than 100. Go ahead and press that key a few times.
1
  • 1
    Sound was low on a usb sound card. This made me realise the settings alsamixer showed me were from the HDA Intel Card. Switched to usb card, and sure enough, PCM was at 20%
    – djib
    Sep 29, 2020 at 7:35
5

Run hdajackretask GUI tool (alsa-tools-gui package in Ubuntu). Find your port, tick Override and choose Headphone, apply.

Surprisingly I got my volume back. Finally. Yay! (I'm using headphones). Sadly almost nobody recommends to try this tool.

4

I had this issue with Ubuntu 18.04. On Windows 10 (dual boot), microphone works as expected. On Ubuntu, I could yell into the microphone and you could barely hear anything on the other end. None of the built-in settings were working including boosting the microphone. I finally found this suggestion which originates from here.

  1. Install pavucontrol
  2. Run pavucontrol and go to the Input Devices tab
  3. Click the unlock button to unlock the channels
  4. Set the Right channel to 0 (left should be above 0, possibly 100%)
4

Run below few times until you are happy. Will raise the sound ALOT.

pactl list | grep -oP 'Sink #\K([0-9]+)' | while read -r i ; do pactl -- set-sink-volume $i +100% ; done

For set default to 100%:

pactl list | grep -oP 'Sink #\K([0-9]+)' | while read -r i ; do pactl -- set-sink-volume $i 100% ; done
2
  • 1
    This effectively doubles the baseline volume. Which works well for me. But be warned, it does amplify the sound significantly.
    – Martin
    Sep 5, 2023 at 18:17
  • 1
    Man. Thanks a lot! I created two scripts from this. increase-volume and normal-volume. totally works. Oct 13, 2023 at 9:32
2

In alsamixer try increasing everything which is not "mic" or "line in". Do it while playing some sound so you will know which channel is responsible. If you have a channel named "Front", try increasing that.

2

In a terminal run alsamixer
Press to go to "Speakers"
Press as many times as you want until sound is ok (for maxed of course!)
Press Esc to exit when you're done

0
2

I know this is an old thread, but none of these fixed my problem for my wireless bose headphones.

The problem for me was the volume control on my headphones is actually separate from the volume control in the OS - which is different than how it works in windows. If you have this problem and are using wireless headphones, try using the buttons on your headphones to increase the volume level.

1
  • 1
    Thanks! This was the issue for me to on Ubuntu 21. I never even thought to do this since the volume controls on the computer were changing the volume and on windows they are linked.
    – Alex Li
    Aug 24, 2021 at 21:54
1

Use paman. With paman you can get a volume higher then 100% as in vlc.

0
1

I had a similar issue with dual-booted Ubuntu 18.04 + Windows 10.

I had very quiet sound on laptop speakers on Linux, but Windows 10 was fine. Using headphones under linux also worked fine. None of the above software solutions worked for me, and the 200% volume setting was still quiet and had very poor sound quality. Rebooting the machine had no effect.

After a couple of days, the issue suddenly fixed itself when I disconnected my USB headphones whilst playing audio.

My guess is that there was some hardware/software switch for detecting if the headphones where plugged in that had not been properly reset.

So try playing some audio, then plug in a set of headphones and yank them out again. Possibly try this a few times and see if this helps.

1

For posterity: Gnome Tweaks, check over-amplify volume.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .