1

I downloaded conky from github: https://github.com/brndnmtthws/conky

then I installed it using this method:

$ mkdir build
$ cd build
$ ccmake /home/user/conky
# this will launch a curses-based UI where you can configure
# everything, when you are ready you can build as usual:
$ sudo make  # This will compile conky in the `src` subdirectory
$ sudo make install

then I wanted to uninstall it; I deleted the directories /build and /conky

and I did sudo apt-get --purge remove conky conky-all

then I rebooted, but conky still starts.

How do I delete conky?

0

There is no 100% sure way to find all new files that were installed during the make install since you removed the build directories that might have contained a list of installed (but usually not the overwritten ones) files.

You might try something like find /directory_path -mtime -1 -ls (stolen from here), but you may run in all kinds of trouble if you did some more building and installing the time frame.

The apt-get method you tried, fails because you confgured, built and installed outside of the integrated package management system that apt is.

In the future when you want to do this again, make at least an index of the files already installed before the make install part and do the same afterwards. Comparing those indexes should give you the installed and overwritten files.

Good luck.

  • 1
    consider downloading the package again, creating the makefile, then running "make uninstall"? – Jeff Schaller Jun 5 '17 at 13:16
  • tried it, didn't work unfortunately. – user1557314 Jun 5 '17 at 13:37
  • That last make uninstall might have failed because conky was still running (a executable file deletion in linux does not actually become effective until all processes using it are ended). Try a reboot. – JdeHaan Jun 5 '17 at 13:41
  • @JdeHaan what? Executables do get deleted even if they’re running. The space they occupy isn’t recovered until all running processes using them have closed the corresponding file descriptor (same as any file on Unix-style systems), but they do disappear from the directory containing them. – Stephen Kitt Jun 5 '17 at 13:58
  • @Stephen Kitt: true, more accurate. – JdeHaan Jun 5 '17 at 14:23
0

I think I got it.

First I reinstalled using the same method then I did this:

killall conky
cd build
make clean
cd
sudo rm -r build
sudo rm -r conky
sudo rm -r /usr/local/bin/conky-1.10.7_pre
sudo rm /usr/local/bin/conky
sudo apt-get update ; sudo apt-get autoclean ; sudo apt-get clean ; sudo apt-get autoremove

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.