0

I've recently become unable to access the MS Onedrive web app. It was working find until about two weeks ago but now all I get is a general connection error saying that the site can't be reached. "The connection was reset. Try: *Checking the connection. *Checking the proxy and the firewall. ERR_CONNECTION_RESET"

I contacted MS support but they were zero help, telling me to go get support from a Linux forum. So...here I am.

I'm running Linux Mint 18 on an old Sony VAIO Duo 11. It works fine at home but not at work (a university), and I can access the web app on the same network with Win & Mac. I have tried turning off the firewall, accessing from a private window, turning off all extensions, and using three different browsers, all to no avail.

To be clear, I'm not trying to use a sync client. I just want to access the web app.

1 Answer 1

0

Looks like a certificate trust error. If apt-get upgrade fails to help, try a recent Mozilla Firefox.

Failing this, you could of course see if you can reach their site using openssl. Something like:

openssl s_client -connect remote:443

If that establishes a connection you know the network layer is ok. Is your browser configured to use a proxy?

6
  • I upgrade every morning and have the most recent version of Firefox. I've also tried Chrome and Opera but still have the same issue.
    – J.M.S.
    Jun 5, 2017 at 8:30
  • Thank for your help, Ed. I can make a connection using openssl (I see the server certificate) and my browser is not configured for proxy. If it helps, I don't have any issues with other services like Dropbox or Google Drive.
    – J.M.S.
    Jun 6, 2017 at 4:20
  • Then it seems that the browser's trust layer is not in sync with the onedrive server certificates. Maybe the ca package on Mint needs updating?
    – Ed Neville
    Jun 6, 2017 at 6:45
  • My ca-certificates package is the latest version available.
    – J.M.S.
    Jun 6, 2017 at 8:44
  • That might have revoked the issuer of the onedrive site. Or google may have done that, for example theregister.co.uk/2016/11/02/…. Another possibility is that the browser version doesn't regard older SSL crypto as secure.
    – Ed Neville
    Jun 7, 2017 at 6:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .