0

I run SlickEdit (IDE) on the Solaris 11 machine and on my windows I run X server (xming/xlaunch).
I dont see fonts in the GUI, i see small squares instead (as in picture below).

I suspect i am missing fonts at /usr/openwin/lib/X11/fonts/

What package should i download and where do i download it from ?

SunOS solaris11 5.11 11.0 i86pc i386 i86pc  
root@solaris11:~# cat /etc/*release  
                           Oracle Solaris 11 11/11 X86  
  Copyright (c) 1983, 2011, Oracle and/or its affiliates.  
  All rights reserved.  
                            Assembled 18 October 2011  
root@solaris11:~#

update: I have another solaris (5.10) that the UI does work, the fonts are working (and in their location), when i list X11 directory there i see the content:

-bash-3.00$ ls -la /usr/openwin/lib/X11/fonts/
total 80
drwxr-xr-x  15 root     bin          512 Mar  9  2008 .
drwxr-xr-x   9 root     bin         1024 Mar  9  2008 ..
drwxr-xr-x   2 root     bin         5120 Mar  9  2008 100dpi
drwxr-xr-x   2 root     bin         5120 Mar  9  2008 75dpi
drwxr-xr-x  14 root     bin          512 Mar  9  2008 CSL
drwxr-xr-x   2 root     bin         1024 Mar  9  2008 encodings
drwxr-xr-x   4 root     bin         2048 Mar  9  2008 F3
drwxr-xr-x   2 root     bin         9216 Mar  9  2008 F3bitmaps
-rw-r--r--   1 root     root         230 Mar  9  2008 fonts.cache-1
drwxr-xr-x   2 root     bin         2560 Mar  9  2008 misc
drwxr-xr-x   2 root     bin          512 Mar  9  2008 Speedo
drwxr-xr-x   3 root     bin         3072 Mar  9  2008 TrueType
drwxr-xr-x   2 root     bin         3072 Mar  9  2008 TTbitmaps
drwxr-xr-x   6 root     bin         1024 Mar  9  2008 Type1
drwxr-xr-x   2 root     bin          512 Mar  9  2008 Type3
drwxr-xr-x   2 root     bin         2048 Mar  9  2008 Xt+
-bash-3.00$

this increases my suspicion something is invalid regarding to fonts. enter image description here

8
  • 1
    X11 fonts should be installed on the X server (e.g. your Windows PC) Jun 5 '17 at 4:55
  • So what am i missing ? My windows is working fine with all other distros.. i do the same thing with linux and it works fine
    – ilansch
    Jun 5 '17 at 4:58
  • I have no idea. Did you try to run some terminal emulator on the Solaris machine, then to start your SlickEdit in that terminal? Perhaps you'll see helpful error messages. BTW consider also switching to another editor (like emacs) Jun 5 '17 at 5:01
  • i have existing machine solaris 5.10 that works - I will try to compare installed packages between machines.. to see what i am missing in the solaris 5.11
    – ilansch
    Jun 5 '17 at 5:04
  • 1
    Play also with xlsfonts and compare the outputs on various machines. Jun 5 '17 at 5:12
0

After installing packages: xorg-core, fonts-core

pkg install xorg-core fonts-core

Everything works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.