1

How do I recompile GNU Screen if I've only ever used apt-get to install packages on ubuntu? How do I recompile a package (in my case, GNU Screen) in order to get 256 colors in Vim?

What I'm trying to do is this: ./configure --enable-colors256 && make && sudo make install so that I can get 256 colors in Vim under GNU Screen.

I set my .screenrc and .bashrc files to the following answer here: https://stackoverflow.com/questions/6787734/strange-behavior-of-vim-color-inside-screen-with-256-colors

But the colorschemes still do not work correctly in GNU Screen. If I'm out of GNU Screen the colorschemes are perfect, just in Screen.

So, I was told that I might have to recompile it to get to work.

Here are my bashrc, vimrc and screenrc files...

.bashrc file

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples
export TERM=xterm-256color
# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

export NVM_DIR="/home/serge/.nvm"
[ -s "$NVM_DIR/nvm.sh" ] && . "$NVM_DIR/nvm.sh"  # This loads nvm

.screenrc file

# An alternative hardstatus to display a bar at the bottom listing the
# windownames and highlighting the current windowname in blue. (This is only
# enabled if there is no hardstatus setting for your terminal)
# hardstatus on
# hardstatus alwayslastline
# hardstatus string "%{.bW}%-w%{.rW}%n %t%{-}%+w %=%{..G} %H %{..Y} %m/%d %C%a "
term screen-256color

.vimrc file

" use visual bell instead of beeping
"set vb
"   
" Basics {
set nocompatible " explicitly get out of vi-compatible mode

" i added this for colorshemes
"set term=xterm-256color

if $COLORTERM == 'gnome-terminal'
      set t_Co=256
  endif

syntax on
syntax enable
colorscheme twilight256
"set bg=dark
"set background=dark


"let g:solarized_termcolors=256 " Added this for solarized

" General {
filetype plugin indent on " load filetype plugins/indent settings
set autochdir " always switch to the current file directory 
set backspace=indent,eol,start " make backspace a more flexible
set fileformats=unix,dos,mac " support all three, in this order
set iskeyword+=_,$,@,%,# " none of these are word dividers
set mouse=a " use mouse everywhere
set whichwrap=b,s,h,l,<,>,~,[,] " everything wraps
set wildmenu " turn on command line completion wild style

" Vim UI {
set laststatus=2 " always show the status line
set linespace=0 " don't insert any extra pixel lines betweens rows
set matchtime=5 " how many tenths of a second to blink matching brackets for
set novisualbell " don't blink
set number " turn on line numbers
set ruler " Always show current positions along the bottom
set showcmd " show the command being typed
set showmatch " show matching brackets
set statusline=%F%m%r%h%w[%L][%{&ff}]%y[%p%%][%04l,%04v]
nnoremap <C-N> :next<Enter> " this replaces :next, when opening multiple files
nnoremap <C-P> :prev<Enter> " this replaces :prev, when opening multiple files
set confirm

" Text Formatting/Layout {
set tabstop=4
set expandtab
set shiftwidth=4 " not sure what this does?
set smarttab autoindent
set softtabstop=4 " when hitting tab or backspace, how many spaces 


" paste mode - this will avoid unexpected effects when you
" cut or copy some text from one window and paste it in Vim.
set pastetoggle=<F2>

" The 3 commands below are an experiment
" save file (ctrl-s)
"   :map <C-s> :w<cr>
" copy selected text (ctrl-c)
"   :vmap <C-c> y
" Paste clipboard contents (ctrl-v)
"   :imap <C-p> <esc>P
  " Press i to enter insert mode, and ii to exit. 
:imap jj <Esc>
:inoremap <C-S> <C-O>:w<CR>


" Filetype-Dependent Settings
filetype plugin on
filetype indent on

set modifiable

" Pathogen related
execute pathogen#infect()
call pathogen#helptags()
syntax on
filetype plugin indent on
  • EDIT: Okay, I did something to the vimrc file I think it fixed the syntax highlighting now. One thing though, it only show the correct background color for the code but leaves the rest of the terminal in a darker color, I guess its the default black color. Any suggestions on how to fix this? Here is a screenshot. screenshot

This is what the colorscheme should look like in gnu screen instead:

enter image description here

Solution:

I needed the following code in my .vimrc file to fix the issue.

if &term =~ '256color' " disable Background Color Erase (BCE) so that color schemes " render properly when inside 256-color tmux and GNU screen. " see also http://snk.tuxfamily.org/log/vim-256color-bce.html set t_ut= endif

closed as off-topic by Stephen Kitt, phk, Anthon, GAD3R, user34720 Jun 6 '17 at 18:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Stephen Kitt, phk, Anthon, GAD3R, Community
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What's not working? Doing what you said (preferably after uninstalling the package) should work. – n.caillou Jun 4 '17 at 17:59
  • 2
    There’s probably some other reason you’re not getting 256 colours — screen is built with --enable-colors256 in Debian and Ubuntu. – Stephen Kitt Jun 4 '17 at 18:16
  • I was told I might have to recompile it. Hopefully I don't but figured I would ask just in case. I edited my post to show my files, just in case there's something wrong there as well. – user8110853 Jun 4 '17 at 18:26
  • When you’re in a screen session, what does echo $TERM show? – Stephen Kitt Jun 4 '17 at 22:01
  • It shows xterm-256color when I issue echo $TERM – user8110853 Jun 4 '17 at 22:38
3

Setting TERM=xterm-256color inside screen is pretty much guaranteed to provide problems. screen's terminal description is reduced (and modified) to fit screen's own model of the terminal. As noted in the comments, recompiling screen will not be useful to you.

Offhand, since you're interested in the bce-feature, you'd need a variation of screen-bce (which doesn't appear to have been requested — see terminal database entries for screen.xterm-256color and screen-bce:

screen-bce.xterm-256color|GNU Screen with xterm using 256 colors, bce flavor,
        use=xterm+256setaf, use=screen-bce,

taking that as a file (say "foo.ti") and compiling it

sudo tic -x foo.ti

would give you something that you could set inside screen:

export TERM=screen-bce.xterm-256color

Not the answer you're looking for? Browse other questions tagged or ask your own question.