1

Half year ago I bought laptop HP EliteBook 850 G3 with Intel i7, 16GB RAM and 512GB SDD. This was my first time when in installator I chose option "full encrypted disk" (don't remember exactly name). I also remember that I had message that device is running on UEFI and question if I want to continue with this mode. I chose YES. I noticed that when run my laptop I have to wait arround 23 seconds for decrypt password. After type it, login screen show up immediately. I don't see any slow down with Mint by itself. UI response, file copying, everything is exremally fast except that long booting. Is it normal, even on such powerfull machine with SSD drive? My previous laptop had Kubuntu installed, not encrypted but one partition was encrypted and mounted via fstab so I also had to type password while booting but it showed up immediately. Just watch this video how it look on HP:

https://drive.google.com/open?id=0B33a2H5HSPjSZlQ4WjNEZ1BLVnc

Could be something wrong with my bios setup? I'm not familiar with all those UEFI, BIOS, AHCPI, FAST BOOT, SECURE BOOT meanings so I attached link to screenshots gallery. Maybe something is wrongly configured here. Also mu grub is:

cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash intel_idle.max_cstate=1"
GRUB_CMDLINE_LINUX="acpi_osi=Linux pcie_aspm=force acpi_enforce_resources=lax drm.vblankoffdelay=1 acpi_backlight=vendor intel_iommu=igfx_off"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Linux Mint 18.1 KDE edition 64bit, updated. Plasma 5.8.6 Kernel 4.10.0-21

Link to gallery: https://drive.google.com/open?id=0B33a2H5HSPjSRFJZYU1jU1I4ejA

UPDATE 2017-07-02 Today I updated HP bios to recent version, also disabled CD boot (even that I don't have CD-ROM), USB boot, network boot and changed secure boot from "Legacy enabled secure boot disabled" to "Legacy DISABLED secure boot disabled" and run time decreased from 23 seconds to 17 seconds. That is good score, although my old Dell laptop start to password box in 14 seconds. I'll try to install on it Linux Mint 18 too and check if it's matter of ubuntu distro

Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.