1

I downloaded and compiled the source code of FreeBSD with:

git clone https://github.com/freebsd/freebsd.git /usr/src
cd /usr/src
make clean
make buildworld

and literally everything would exit on signal 12. I tried rebooting the system, but reboot exited on signal 12, so I had to press the power button to shutdown my device. When I boot to FreeBSD again, I can't even login. Firstly it tells me

Jun 4 08:10:32 init: /bin/sh on /etc/rc terminated abnormally, going to single user mode
Enter full pathname of shell or RETURN for /bin/sh:

And if I send a RETURN, an error would occur:

pid 33 (sh), uid 0: exited on signal 12
Jun 4 08:10:51 init: single user shell terminated, restarting
Enter full pathname of shell or RETURN for /bin/sh:

The worst thing about this problem is that the same error occurs even when I enter Single User Mode.

How can I fix this?

  • freebsd.org/doc/en_US.ISO8859-1/books/handbook/makeworld.html shows other steps, such as make kernel though I don't see where you ran installworld to install things? What exact steps did you follow? – thrig Jun 4 '17 at 0:53
  • @thrig I wasn't follow any steps. Actually, I just needed to download the source code, so that a ===> bwn-firmware-kmod-0.1.2 requires kernel source files in /usr/src error can be solved. However, after downloading the source, I thought "since I have the source code, why not compile them?", so I ran make buildworld, and everything exited on signal 12... – nalzok Jun 4 '17 at 1:04
  • Suggest you try to boot in to safe mode. If that fails you should be able to rescue the drive contents with a Live CD of some sort. Personally I've had some pretty major issues but nothing that stopped single user mode except a few failed drives. Also read the handbook :] – Tigger Jun 4 '17 at 3:57
  • This is likely due to the kernel and userland being out of sync. Boot from a Live CD and download/compile a new kernel first. – Kusalananda Jun 4 '17 at 6:44
  • Maybe you are out of the disk space? – arrowd Jun 4 '17 at 10:28
1

You had a bad luck to upgrade your system at a very rare moment of the CURRENT branch changing its ABI, and ignore the safe procedure detailed here (the 20170523 entry):

https://github.com/freebsd/freebsd/blob/master/UPDATING

At this point - old kernel, new userland, which is the only unsupported configuration there is (new kernel, old userland is fine) - I'd say the easiest way out is to reinstall, without reformatting partitions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.