4

I have an Asus-X550LD with Windows 7 installed, and for the past few hours I have been unsuccessfully trying to install Linux Mint on my machine in order to create a dual boot system.

I wrote the Mint image file into a USB using Rufus with the option "MBR partition scheme for BIOS or UEFI". But when I tried to install after booting into the Live version, I got the following error:

Force UEFI Installation
This machine's firmware has started the installer in UEFI mode but it looks like there may be existing operating systems already installed using "BIOS compatibility mode". If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later.

If you wish to install in UEFI mode and don't care about keeping the ability to boot one of the existing systems, you have the option to force that here. If you wish to keep the option to boot an existing operating system, you should choose NOT to force UEFI installation here.

When I searched around the internet, I found that I needed to boot in Legacy mode instead of UEFI mode. But, I can't seem to do that from my BIOS.

Following are some screenshots of my BIOS:Image 1 Image 2

As you can see in Image 1, the only option I have is to boot my USB in UEFI. I changed other settings, but still can't seem to boot it in Legacy mode.

How do I solve this? Any help would be much appreciated. Thanks!

  • How do you create the bootable USB? – GAD3R Jun 3 '17 at 20:02
  • 1
    If you have create the bootable USB through Rufus to boot Legacy and UEFI , Clic on the "Boot option #1" , you will see your USB listed 2 time : the first to boot on the EFI mode and the 2 nd to boot the legacy mode – GAD3R Jun 3 '17 at 20:13
  • @GAD3R I use the Boot Option #1/"MBR partition scheme for BIOS or UEFI" while creating the bootable USB in Rufus. But still, I don't get the option to boot in Legacy. I just have this option: "UEFI: SanDisk" (Image 1). When I click on "Hard Drive BBS Priorties" (Image 1), it just mentions "SanDisk". Nowhere did I find "Legacy"/"BIOS" together with "SanDisk" – Stack-Boi Jun 3 '17 at 21:24
  • @GAD3R I do get the option to start Mint in "Compatibility Mode" when I boot from the USB, but this still gives me the "Force UEFI Installation" message when I try to install – Stack-Boi Jun 3 '17 at 21:31
  • Yes there are a problem when trying to install some linux disto on legacy boot on Asus-X550...., Forcing the installation will break windows and the linux mint will not be installed correctly. – GAD3R Jun 3 '17 at 21:51
1

You have to change "Launch CMS" from "enable" to "DISABLE". If you still have problem after this, you'll have to create a non UEFI usb live.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.