2

I want to install openssh-server on my server, but it shows me :

apt-get install openssh-server

Reading package lists... Done
Building dependency tree       
Reading state information... Done
openssh-server is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 upstart : Depends: ifupdown (>= 0.6.10ubuntu5)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

when I try to apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  python-numpy python-gobject-2 python-gobject-dev libpython2.7 docbook-xml
  docbook-xsl python-dev libgirepository-1.0-1 liblapack3gf libffi-dev
  libquadmath0 libffi5 python-gi libssl-dev python2.6-dev libglade2-0
  libblas3gf gir1.2-glib-2.0 python-gobject sgml-data libgfortran3
  python2.7-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  ifupdown
Suggested packages:
  ppp rdnssd
The following packages will be upgraded:
  ifupdown
1 upgraded, 0 newly installed, 0 to remove and 325 not upgraded.
9 not fully installed or removed.
Need to get 0 B/48.3 kB of archives.
After this operation, 43.0 kB disk space will be freed.
Do you want to continue [Y/n]? y
y
Reading changelogs... Done
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on upstart-job; however:
  Package upstart-job is not installed.
  Package upstart which provides upstart-job is not configured yet.
 plymouth depends on udev (>= 166-0ubuntu4); however:
  Package udev is not configured yet.
dpkg: error processing plymouth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mountall:
 mountall depends on udev; however:
  Package udev is not configured yet.
 mountall depends on plymouth; however:
  Package plymouth is not configured yet.
dpkg: error processing mountall (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of initscripts:
 initscripts depends on upstart; however:
  Package upstart is not configured yet.
 initscripts depends on mountall (>= 2.28); however:
  Package mountall is not configured yet.
dpkg: error processing initscripts (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
 plymouth
 mountall
 initscripts
E: Sub-process /usr/bin/dpkg returned an error code (1)

so I tried to install deb files with dpkg -i --force-overwrite but again shows me error.

lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 6.0.10 (squeeze)
Release:    6.0.10
Codename:   squeeze

apt-cache policy

Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.debian.org/debian/ jessie-backports/main Translation-en
 100 http://ftp.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin ftp.debian.org
 100 http://ftp.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin ftp.debian.org
 500 http://deb.debian.org/debian-security/ stable/updates/main Translation-en
 500 http://deb.debian.org/debian-security/ stable/updates/main i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin deb.debian.org
 500 http://deb.debian.org/debian-security/ stable/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable-updates/non-free Translation-en
 500 http://deb.debian.org/debian/ stable-updates/main Translation-en
 500 http://deb.debian.org/debian/ stable-updates/contrib Translation-en
 500 http://deb.debian.org/debian/ stable-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable-updates/contrib i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable/non-free Translation-en
 500 http://deb.debian.org/debian/ stable/main Translation-fr
 500 http://deb.debian.org/debian/ stable/main Translation-en
 500 http://deb.debian.org/debian/ stable/contrib Translation-en
 500 http://deb.debian.org/debian/ stable/non-free i386 Packages
     release v=8.8,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable/contrib i386 Packages
     release v=8.8,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable/main i386 Packages
     release v=8.8,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable/non-free amd64 Packages
     release v=8.8,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable/contrib amd64 Packages
     release v=8.8,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin deb.debian.org
 500 http://deb.debian.org/debian/ stable/main amd64 Packages
     release v=8.8,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin deb.debian.org
Pinned packages:

any idea ?

  • 3
    Could you edit your question to show the output of apt-cache policy? You seem to have a mixture of Debian and Ubuntu somehow. – Stephen Kitt Jun 3 '17 at 15:24
  • Please add the output of the cat /etc/apt/sources.list and ls /etc/apt/sources.list.d . – GAD3R Jun 3 '17 at 15:55
  • You somehow managed to install the Ubuntu version of plymouth and upstart. You need to install the Debian version instead. – psusi Jun 3 '17 at 16:30
3

You may want to try purging the installation and cleaning up apt a bit.

Try:

sudo apt-get remove openssh-server openssh-client --purge && sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get update

If you don't have any reason not to upgrade packages then also try:

sudo apt-get dist-upgrade

You can then try installing the packages again to see if this resolved the issue:

sudo apt-get install openssh-server openssh-client

Edit:

Noticed that ubuntu is referenced in the error: upstart : Depends: ifupdown (>= 0.6.10ubuntu5)

Check your sources.list file and sources.list.d directory files for any references to ubuntu. If there are comment them out and try the above commands again.

If any ubuntu PPA's or ubuntu .deb packages are installed this could also cause issues.

  • Thats a shame - sorry I couldn't be of more help. Have you also tried sudo dpkg --configure -a by any chance? – Sabe Barker Jun 3 '17 at 14:45
  • Hmm.. is your OS ubuntu or debian? There are a few references to ubuntu in those errors? Do you have any added PPA's or anything added to the sources.list file? – Sabe Barker Jun 3 '17 at 15:28
  • Yes, so there shouldn't be any references to ubuntu then? upstart : Depends: ifupdown (>= 0.6.10ubuntu5) and debian squeeze has ifupdown_0.7.8 in it's repo it seems. – Sabe Barker Jun 3 '17 at 15:44
  • No problems. Glad I could help! – Sabe Barker Jun 3 '17 at 23:36
0

With special thanks to All of you I changed the sources.list to :

deb http://deb.debian.org/debian/ oldstable main contrib non-free
deb-src http://deb.debian.org/debian/ oldstable main contrib non-free

deb http://deb.debian.org/debian/ oldstable-updates main contrib non-free
deb-src http://deb.debian.org/debian/ oldstable-updates main contrib non-free

deb http://deb.debian.org/debian-security oldstable/updates main
deb-src http://deb.debian.org/debian-security oldstable/updates main

deb http://ftp.debian.org/debian wheezy-backports main
deb-src http://ftp.debian.org/debian wheezy-backports main

and it worked, oldstable was important I think.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.