1

Same as above. Recently I broke my system and then wiped and reinstalled. I initially managed to get python 3.6 working in Pycharm with a new installed before breaking things again. I didn't do anything special and merely retraced my steps only to find Pycharm only seeing 2.7 and 3.5 instead of 3.6 on my 3rd install.

I want to make use of the most current version of Python due to the features it's released. How do I set up environment variables to recognize 3.6.1 for development purposes? I did it a few times on Windows but merely went into Advanced system settings and added a few lines in a window.

I installed Python 3.6.1 successfully on Mint; How can I duplicate the above process for Pycharm on Linux?

0

Try File -> Settings... -> Project -> Project interpreter -> click on the little wheel and select Add local and then select your 3.6.1 environment

  • Despite installing it using these instructions: tecadmin.net/install-python-3-6-ubuntu-linuxmint It didn't work. I then tried adding a ppa from this: askubuntu.com/questions/865554/… and got these errors: – Lusus Naturae Jun 3 '17 at 10:39
  • ImportError: cannot import name '_remove_dead_weakref' dpkg: error processing package python3.6-minimal (--configure): subprocess installed post-installation script returned error exit status 1 Setting up libpython3.6-stdlib:amd64 (3.6.1-1~16.04.york0) ... dpkg: dependency problems prevent configuration of python3.6: python3.6 depends on python3.6-minimal (= 3.6.1-1~16.04.york0); however: Package python3.6-minimal is not configured yet. – Lusus Naturae Jun 3 '17 at 10:41
  • dpkg: error processing package python3.6 (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: python3.6-minimal python3.6 E: Sub-process /usr/bin/dpkg returned an error code (1) – Lusus Naturae Jun 3 '17 at 10:41
  • I am unable to change the interpreter from 2.7 or 3.5 as default choices. There is nothing to select in the drop down menu that mentions anything other than 2.7 or 3.5 – Lusus Naturae Jun 3 '17 at 10:42
  • What errors did you get when you try to install python with the first link you posted? – ceccoemi Jun 3 '17 at 10:57
0

I don't know if we can force a project to use a specific before configuring it first. PyCharm auto detects available interpreters and we will have to configure the project to use a specific interpreter and give it a name.

The following is from the Help docs from PyCharm:

https://www.jetbrains.com/help/pycharm/configuring-python-interpreter-for-a-project.html

PyCharm helps assign a Python interpreter for a project.

So doing, each one of the projects, opened in the same window, can have an interpreter of its own, selected from the list of available interpreters.

Note that PyCharm stores only the interpreter name in the project settings.

To configure Python SDK for the current project, follow these steps:

  1. Open the Settings/Preferences dialog box, and click Project Interpreter page.
  2. In the Projects pane, choose the desired project.
  3. Choose SDK from the list of available Python interpreters and virtual environments. This list includes:
    • Python interpreters, which reside in standard locations.
    • Virtual environments, which reside under the project folder, or under the folder specified as an environment variable WORKON_HOME.
    • Other Python interpreters, installed locally or remotely.
  4. If the desired interpreter is not in the list, click the cogwheel icon, and configure the desired interpreter as described in the section Configuring Available Python Interpreters.

https://www.jetbrains.com/help/pycharm/configuring-available-python-interpreters.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.