0

So, the problem here is that my audio worked before this.

Last night, I left my computer on. When I woke up, I tried to wake it from sleep, but it seemed it had crashed for some reason. I restarted my computer, and it worked fine, except the audio is gone.

I really have no idea what is going on, except that Debian is completely ignoring my motherboard audio card all of a sudden. I tested audio recording in Audacity, and I was getting a record signal, but it was just noise from the look of it, and had no correlation to my actual microphone.

My settings say I am using alsa with PULSE, which is normal.

The only information I can give is that I did attempt to get some OSS compatibility packages, but that was a couple days ago, and I have surly restarted my computer since then.

If you need any system information, let me know in the comments and I will post it.

EDIT:

In the audio manager, all of my audio devices have been replaced wit "Dummy Output," and the normal devices are not selectable, but listed. My normal device, called "Built-in Audio Analog Stereo" is one of these devices I can't select, meaning that my audio will not work until I can get that device working. Maybe I edited the modules when working with the OSS stuff, causing the devices to not be selectable?

EDIT:

/proc/asound does not exist, which is an issue...

  • 1
    Could we get the output of cat /proc/asound/cards? – derobert Jun 2 '17 at 16:50
  • @derobert sure thing! One sec... – SpecialBomb Jun 2 '17 at 16:54
  • @derobert It appears that /proc/asound doesnt exist, thats alarming... – SpecialBomb Jun 2 '17 at 16:55
  • 1
    BTW, random aside, I'd like to introduce you to etckeeper. Easily puts /etc under version control, so you can quickly see what you changed—even if it was at the end of a late night of trying to get this #(@!# thing to work. – derobert Jun 2 '17 at 17:03
  • 1
    @derobert okay, found some more packages involving oss, and uninstall purged all of them. Restarting now... – SpecialBomb Jun 2 '17 at 17:15
3

Uninstall (purge) any oss replacement packages, like oss4-base.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.