2

I used to have many choices about sound/audio hardware:

analogue sterio output

surround sterio output

analogue HDMI sterio output ... etc

enter image description here

now they seem missiong and also virtual box shows the message :

No audio devices could be opened.

obviously there is a problem with the sound drivers. I removed everything and re installed pulse and alsa I even reinstalled the kernel nothing seems to work

by the way the sound works perfectly but I have these issues: when using headphones I must each time

use alsamixer to unmute the headphones and increase their volume and the sound does not go out by HDMI (to the TV monitor)

$ inxi -AS
System:    Host: mmmmmm-pc Kernel: 4.4.0-78-generic x86_64 (64 bit)
       Desktop: MATE 1.16.1  Distro: Linux Mint 18.1 Serena
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
       driver: snd_hda_intel
       Sound: Advanced Linux Sound Architecture v: k4.4.0-78-generic
$ 
  • In Pulseaudio, many variations are shown via pavucontrol, either as profile choices in the configuration tab, or as ports in the output/input devices tabs. The Linux Mint menu may or may not offer all this choices, in doubt, try pavucontrol. Number of channels (stereo vs. surround) is now handled automatically. The huge number of devices you had in ALSA isn't necessary any longer. – dirkt Jun 3 '17 at 9:06
  • I installed pavucontrol i showed the Connection to PulseAudio failed error ! – Neo Mosaid Jun 3 '17 at 10:29
  • Check with ps if Pulseaudio is running. If it's not running, you can start it manually with pulseaudio --start (then the question is why it doesn't start automatically). Also do aplay -l and edit your question with the output to see if ALSA is working. Additionally, do aplay -L to see if ALSA automatically assigns your "missing" devices (though you won't need them under Pulseaudio). – dirkt Jun 3 '17 at 13:41
  • I removed pulseaudio completely because caused many problems mainly pulseaudio daemon startup fail pulse audio volume control unable to connect to pulse audio server... – Neo Mosaid Jun 4 '17 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.