15

I am unable to enter anything at the login screen; it just freezes directly after the page shows. The cursor inside the login form blinks about 10 times, then it stops. I can't move the mouse or use the keyboard.

I already entered the secure mode and triggered update, upgrade and dist-upgrade via the root shell it made no difference.

3 Answers 3

20

We were able to solve it by starting the shell in secure mode and executing the following commands.

  apt-get update 
  apt-get install xserver-xorg-input-all
  apt-get install ubuntu-desktop
  apt-get install ubuntu-minimal
  apt-get install xorg xserver-xorg
  apt-get install xserver-xorg-input-evdev    //I think this packet was the problem
  apt-get install xserver-xorg-video-vmware

  reboot
4
  • 2
    Thank you, this solved my exact problem. I was trying to fix problems with my video and followed this askubuntu.com/questions/763672/… and after reboot got the same problem as you (don't know if it was because of what I did or not). I installed xserver-xorg-input-all which pulled in xserver-xorg-input-evdev and now it works again.
    – Kayaman
    Commented Aug 22, 2017 at 19:47
  • 3
    apt-get update then apt-get install xserver-xorg-input-evdev then /etc/init.d/lightdm restart worked for me. Of course, I did these as root user.
    – User1
    Commented Feb 20, 2018 at 2:37
  • @User1, add this as an Answer please, not as comment. Thanks for your solution!
    – Black
    Commented Feb 20, 2018 at 11:00
  • A variation on this solved my problem. "sudo apt-get update" then "apt-get install xserver-xorg-input-all", during that install it was suggested to install xinput, so "sudo apt-get install xinput". After a reboot things were back to normal.
    – glaucon
    Commented Mar 21, 2023 at 3:57
8

To Simplify @Black's answer, run these as root:

apt-get update
apt-get install xserver-xorg-input-evdev
/etc/init.d/lightdm restart

No reboot required on this solution.

4
  • Also needed xserver-xorg-core as a dependency for xserver-xorg-input-evdev but still didn't work.
    – Shayan
    Commented Jun 9, 2019 at 21:47
  • @Shayan: did the original poster "Black" 's answer work for you? Commented Aug 25, 2019 at 23:57
  • @User1 Did this leave you at a black screen with only a flashing white cursor "_" (underscore) on it? EDIT: I had to make sure my ethernet was actually working so it could really download "xserver-xorg-input-evdev" Commented Aug 26, 2019 at 2:17
  • 1
    @frank no it did not, what actually worked for me at the end was this: askubuntu.com/a/1051125/777279 as far as I remember.
    – Shayan
    Commented Aug 26, 2019 at 18:23
3

I tried everything, for weeks, all day long. I finally went to Driver Manager and changed my video driver to NVIDIA, and that fixed it.

Ironically, NVIDIA was the recommended setting. No idea why that wasn't chosen. It wasn't me - Linux set that.

Anyway, let me know. YMMV.

1
  • 1
    Linux doesn't set jack. Maybe some of the Ubuntu topping which is supposed to do some magic in the back. Anyway, I'm voting down because this is not a real answer. No background on how this solution works, no documentation that explains anything. Just a best guess.
    – Tim
    Commented Jul 12, 2018 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .