3

I use Ubuntu 11.04, and I work at an institution which has wired and wireless connectivity. My computer is set to automatically connect to the wireless network if it is available.

When I am plugged into the wired network, Ubuntu still tries to automatically connect to the wireless network, even though it's the same network.

In Windows, if I am plugged into the wired network, my computer does not attempt to connect to the wireless network. This is the functionality I would like.

Is this possible to achieve under Ubuntu?

  • 2
    A "wireless hardware" kill switch is a surprisingly simple solution here - does your computer have one? – sr_ Apr 19 '12 at 13:46
  • 1
    @user15319 I experienced something similar when I was testing Ubuntu 11.04 on my laptop. It was annoying because when it would connect to the wireless along with the wired network it constantly caused problems with me access the internet. As sr_ said, the easiest way around this is simply turning off the wireless while you are hard-wired in. – SirCobalt Apr 19 '12 at 15:28
  • Is it actually a problem? I'd hope it defaults the traffic over the wired interface… – derobert Sep 25 '12 at 18:00
2

As buddies said the simplest way is to power off wireless adapter using its hardware switch.

But if your computer hasn't such a switch, go to system>preference>network connections; now go to the wireless section (second tab), select the wireless adapter that automatically connects to access point from list, click edit button,in this window, uncheck "Connect Automatically" and click apply. it seems that the problem will not arise again.

0

Update: The essence of Sam's accepted answer also works for Ubuntu 16.04, although on 16.04's newer interface the go-to is of a newer order: Click the gear icon, then click System_Settings>Network>Wireless . Then at the far right of each of the listed wireless connections shown click the orange right arrow, then click on the Settings button. On the next window that pops up, click on the General tab and deselect "Automatically connect when available". Do that for all available wi-fi connections (I also clicked Forget on old connections that I knew I'd never use again.) Last, but not least, go back up to System_Settings>Network and click into the WIRED item. You must have a wired connection plugged into the RJ-45 when you click Options! Then click the General tab and select "Automatically connect when available".

After I did all of the above, my wired connection was the top default connection. After being connected to wifi, just plugging the active ethernet patch cord into the RJ-45 plug made my computer switch the active connection from wifi to wired.

Thank you, Sam!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.