0

I have a problem while loading into Ubuntu 17.04. This happens for the 2nd time after I booted into Windows. For the 1st time I just reinstalled the Ubuntu. I am not good at this question, so I hope to get a full list of steps to diagnose and resolve this issue. Error stack

As a workaround e2fsck -b <Magic number> <device> has been used.

Here is the output of fdisk -l and it is seems fine to me:

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F3EBBDD3-ABDB-4AD4-BBFB-9F97E38D2A2B

Device          Start        End    Sectors   Size Type
/dev/sda1        2048    2050047    2048000  1000M Windows recovery environment
/dev/sda2     2050048    2582527     532480   260M EFI System
/dev/sda3     2582528    4630527    2048000  1000M Lenovo boot partition
/dev/sda4     4630528    4892671     262144   128M Microsoft reserved
/dev/sda5     4892672 1029873663 1024980992 488.8G Microsoft basic data
/dev/sda6  1029873664 1541873663  512000000 244.1G Microsoft basic data
/dev/sda7  1541873664 1737185279  195311616  93.1G Linux filesystem
/dev/sda8  1737185280 1741185023    3999744   1.9G Linux swap
/dev/sda9  1741185024 1953523711  212338688 101.3G Linux filesystem
  • Another person had this problem a few days ago. unix.stackexchange.com/questions/367700/… Can you check if your partitions are overlapping? – Mark Plotnick Jun 1 '17 at 15:51
  • @MarkPlotnick thanks, I checked that. I didn't found any of overlapped partitions. I've repaired the system by running e2fsck <Magic Number> /dev/sda7 and e2fsck <Magic Number> /dev/sda7. But, I want to get the root cause of this behavior. Nothing extraordinary was done last time. And I'm using the same disk partitioning that I used before on Ubuntu 16.04, excpt that I've resized the partitions. – kozlone Jun 1 '17 at 20:48
  • Today after booting into Windows I tried to load Ubuntu and got the same error. Never happened to me before. I've had dual-boot for years and it's worked perfect. – kozlone Jun 27 '17 at 9:30
1

I've found solution here

64bit and metadata_csum features should be disabled

sudo tune2fs -O ^metadata_csum,^64bit /dev/sdXX
0

As I have tried the solution in the main answer for a superblock problem I simply got the same error.

My problem was that my Ubuntu system would not boot (under a multi-boot scenario) and couldn't be mounted from a different Linux system. In a live session gparted reported bad superblock.

I have followed this solution here, but the first step was enough for me.

In a live environment I did something like:

sudo fsck.ext4 -v /dev/sda6

which reported the same problem but also offered to fix. I selected "y" for "yes" several times and then "a" (fix all I guess).

Everything worked after that, but only until the next Windows (7) boot. The culprit in my case was the Windows program ext2fsd - as said here - and removing that fixed this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.