1

I'm trying to install qubes OS, it's nearly complete there only seems to be one issue left.

Some background first: Both Windows and Ubuntu have at one point successfully booted in UEFI mode. Their entries look like so:

Boot0001* ubuntu HD(1,GPT,0cb1782e-aa4f-4227-9f71-9cfc52abc53f,0x800, 0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0002* Windows Boot Manager HD(1,GPT,0cb1782e-aa4f-4227-9f71-9cfc52abc53f,0x800, 0xfa000)/File(\EFI\Microsoft\Boot\...)

These entries show up in the boot menu, even though their respective bootloaders have long since been overwritten by changes made while installing qubes.

After the installation no boot options showed up anymore. Qubes has added an entry to the efi bootloaders that looks like this:

Boot0003* Qubes HD(1,0,0000000000000...0000,0x0, 0x0)/File(\EFI\qubes\xen.efi)

It appears as if this line makes the bios thinks something is malformed, which makes it remove all entries from the boot options.

When I force the bootoptions back like so:

efibootmgr -o 3,2,1

And verify at the bootorder everything looks fine:

efibootmgr -v
BootOrder: 0003,0002,0001

But after a reboot these entries will have been removed, and a subsequent listing with efibootmgr -v will show the entries, but they will not be in bootorder.

Question here

How can I force/correct/modify Qube's entry to have the correct disk GUID? Is perhaps the loaded version of efibootmgr outdated or bugged? Should I try to boot into ubuntu and use that bootmgr (since that appeared to be working). Or is there some other issue, and should this work?

Also:

/etc/fstab does not appear to show the disk UUID, neither and blkid /dev/nvme0n1 output does not match with the UUID that both windows and ubuntu used in their entries.

1

I've found a way to get around this problem. My guess was right and the entry was corrupted to such a fashion that the bios saw fit to delete all the entries.

The solution in this case was to use the built-in bios tool to look for uefi bootloaders.

This article describes how to use the built-in tool to add a uefi boot option in the dell bios (which is the brand of laptop I installed my system on).

https://www.dell.com/support/article/us/en/04/SLN142679/how-to-enable-boot-from-dvd-option-with-uefi-boot-mode-enabled--windows-8--81--10-?lang=EN

Future reference, if the link no longer works the tool can be found under:

Settings -> General -> Boot sequence:

1. Select: Boot list options: UEFI [x] Legacy: []
2. Click: Add Boot option -> Browse disk to .EFI bootloader.=

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.