1

I am trying to install the epel-release package from the CentOS extras repository, but the repository seems to be empty. (I'm also pretty new to linux)

When I run yum repolist:

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
repo id                          repo name                             status
base/7/i386                      CentOS-7 - Base                       7,114
extras/7/i386                    CentOS-7 - Extras                         0
updates/7/i386                   CentOS-7 - Updates                    1,437
repolist: 8,551

When I run yum list extras:

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile

I have tried running yum clean all and yum update, but nothing has seemed to work.

Output of hostnamectl:

 Static hostname: localhost.localdomain
       Icon name: computer-vm
         Chassis: vm
      Machine ID: 4925cfdbb53e4e18b5ce1e3bd2d4ce0d
         Boot ID: b3109364c8a14af9b37a81599f900755
  Virtualization: oracle
Operating System: CentOS 7 (AltArch)
     CPE OS Name: cpe:/o:centos:centos:7
          Kernel: Linux 3.10.0-514.16.1.el7.centos.plus.i686
    Architecture: x86

Output of rpm --query centos-release:

centos-release-7-3.1611.el7.centos.i686
0

yum list extras is actually a regular yum command. What you are looking for is probably repoquery -a --repoid=extras. The "repoquery" command is part of the "yum-utils" package.

0

epel.repo is also at EPEL https://fedoraproject.org/wiki/EPEL → → https://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-9.noarch.rpm ... Besides that: The package is in extras/ too.

Install the downloaded epel.repo # cd Downloads/ && yum install epel-release-7-9.noarch.rpm

About the "yum repolist" : Don't know what the "extras/7/i386" is about. There aren't any: http://mirror.centos.org/centos/7.3.1611/ >>> http://mirror.centos.org/centos/7.3.1611/extras/ ... There are four .i686 packages. + 268 .noarch . And: Are you sure that extras is set to enabled=1 ? My yum repolist is this ( CentOS 7.3-1611 ) :

repo id                  repo name                                      status
!base/7/x86_64           CentOS-7 - Base                                9,360+3
!centos-sclo-rh/x86_64   CentOS-7 - SCLo rh                               5,174
!centos-sclo-sclo/x86_64 CentOS-7 - SCLo sclo                               403
!epel/x86_64             Extra Packages for Enterprise Linux 7 - x86_64  11,722
!extras/7/x86_64         CentOS-7 - Extras                                  380
!updates/7/x86_64        CentOS-7 - Updates                               1,838
repolist: 28,877

A copy of latest CentOS-Base.repo is here https://drive.google.com/file/d/0B7S255p3kFXNSG10b0lXeTUtRzA/view?usp=sharing

  • Is there a way to fix my extras repo? I've added my specs to the main post. – Misys May 31 '17 at 22:32
  • Please see my edited post : A copy of CentOS-Base.repo was uploaded. .... I didn't know about any i686 version of CentOS 7. – Knud Larsen May 31 '17 at 22:36
  • Found the "CentOS 7 (AltArch)" : mirror.centos.org/altarch/7/isos/i386 . Probably installed because your host OS is 32bits. – Knud Larsen May 31 '17 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.