2

By checking the state of installed package using the pkg audit -F tool on freeBSD 11 , I have found 4 vulnerability on the installed packages (installed through pkg) : samba ,OpenEXR , kdelibs and ImageMagick .

I have upgraded ImageMagick and samba to the latest version ( + following the mitigation guide for samba : adding nt pipe support = no to nsmb.conf) .

#pkg search samba
p5-Samba-LDAP-0.05_2           Manage a Samba PDC with an LDAP Backend
p5-Samba-SIDhelper-0.0.0_3     Create SIDs based on G/UIDs
samba-nsupdate-9.8.6_1         nsupdate utility with GSS-TSIG support
samba42-4.2.14_1               Free SMB/CIFS and AD/DC server and client for Unix
samba43-4.3.13_2               Free SMB/CIFS and AD/DC server and client for Unix
samba44-4.4.13                 Free SMB/CIFS and AD/DC server and client for Unix
samba45-4.5.8                  Free SMB/CIFS and AD/DC server and client for Unix
samba46-4.6.2                  Free SMB/CIFS and AD/DC server and client for Unix

There is no upgrade available for OpenEXR and kdelibs , the latest version is already installed.

I am using the KDE4 on FreeBSD 11 , the kdelibs vulnerability affect Linux and Unix systems with the KDE4/KDE5 desktop environment.

How to mitigate the multiple vulnerability : remote code execution and local privilege escalation on FreeBSD 11?

# pkg audit -F
vulnxml file up-to-date
ImageMagick7-7.0.3.7_1 is vulnerable:
ImageMagick -- multiple vulnerabilities
CVE: CVE-2017-9144
CVE: CVE-2017-9143
CVE: CVE-2017-9142
CVE: CVE-2017-9141
CVE: CVE-2017-8830
CVE: CVE-2017-8765
CVE: CVE-2017-8357
CVE: CVE-2017-8356
CVE: CVE-2017-8355
CVE: CVE-2017-8354
CVE: CVE-2017-8353
CVE: CVE-2017-8352
CVE: CVE-2017-8351
CVE: CVE-2017-8350
CVE: CVE-2017-8349
CVE: CVE-2017-8348
CVE: CVE-2017-8347
CVE: CVE-2017-8346
CVE: CVE-2017-8345
CVE: CVE-2017-8344
CVE: CVE-2017-8343
CVE: CVE-2017-7943
CVE: CVE-2017-7942
CVE: CVE-2017-7941
CVE: CVE-2017-7619
CVE: CVE-2017-7606
CVE: CVE-2017-7275
CVE: CVE-2017-6502
CVE: CVE-2017-6501
CVE: CVE-2017-6500
CVE: CVE-2017-6499
CVE: CVE-2017-6498
CVE: CVE-2017-6497
CVE: CVE-2017-5511
CVE: CVE-2017-5510
CVE: CVE-2017-5509
CVE: CVE-2017-5508
CVE: CVE-2017-5507
CVE: CVE-2017-5506
WWW: https://vuxml.FreeBSD.org/freebsd/50776801-4183-11e7-b291-b499baebfeaf.html

kdelibs-4.14.30_1 is vulnerable:
kauth: Local privilege escalation
CVE: CVE-2017-8422
WWW: https://vuxml.FreeBSD.org/freebsd/0baee383-356c-11e7-b9a9-50e549ebab6c.html

OpenEXR-2.2.0_7 is vulnerable:
OpenEXR -- multiple remote code execution and denial of service vulnerabilities
CVE: CVE-2017-9116
CVE: CVE-2017-9115
CVE: CVE-2017-9114
CVE: CVE-2017-9113
CVE: CVE-2017-9112
CVE: CVE-2017-9111
CVE: CVE-2017-9110
WWW: https://vuxml.FreeBSD.org/freebsd/803879e9-4195-11e7-9b08-080027ef73ec.html

samba46-4.6.2 is vulnerable:
samba -- remote code execution vulnerability
CVE: CVE-2017-7494
WWW: https://vuxml.FreeBSD.org/freebsd/6f4d96c0-4062-11e7-b291-b499baebfeaf.html

4 problem(s) in the installed packages found.
  • 1
    Thxs for the heads up, using 12 at home, will check it later on – Rui F Ribeiro May 31 '17 at 15:18
  • 1
    a FreeBSD 12 update solved all bugs, except OpenEXR – Rui F Ribeiro Jun 1 '17 at 19:10
4
  • KDE bug - No mitigation. Update to kauth >= 5.34 and kdelibs >= 4.14.32 (when released) is the solution provided by KDE folks. Just wait for the updated port to have this problem fixed.
  • OpenEXR bugs - No mitigation, and the devs are not showing any sign that they will fix this soon. Best guess here is to remove this package, if you don't really use it (neither is a dependency).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.