-1

So here I found out that my mainboard B250 PC MATE is apparently not working with non-Windows operating systems with UEFI* and now I'm wondering whether it would be better to get a new mainboard or to use legacy BIOS instead of UEFI.

Here people said that UEFI is not required to make use of > 2TB non-boot drives. Is there anything else I need to know to make use of such drives which already have data on them under Debian with legacy BIOS?

Also doesn't UEFI have some other features that I would miss? Would they be worth buying a new mainboard? It seems as of right now Debian/UEFI doesn't support secure boot but I hoped that would change in the future.

If you'd recommend me buying a new mainboard how can I be sure that the other one works properly with UEFI?

*I find this unacceptable by MSI and potentially UEFI and hope that others do too; let's do sth about it!

Update: So now I tried it with legacy BIOS, without encryption and without separate home partition. I'm still having the same problem so I'm not sure what the cause is but it doesn't seem to be UEFI. Any ideas?


Update 2: Alright, so now I tried starting it without anything connected to USB (mouse and keyboard). It didn't help and I'm still getting those same errors. When entered lsusb I got:
Linux Foundation 3.0 root hub and " 2.0 root hub (twice each) and "Logitech, Inc. HID-Compliant Keyboard".
When entering cd /var/log/ ls I get:
alternatives.log, apt, auth.log, btmp, daemon.log, debug, dmesg, dpkg.log, exim4, faillog, fontconfig.log, fsck, installer, kern.log, lastlog, messages, syslog, wtmp, Xorg.0.log, Xorg.0.log.old
When entering dmesg I get (only some of the bottom messages; not sure how to scroll up right now):

usb 1-3: device descriptor read/64, error -71  
usb 1-3: new low-speed USB device number 12 using xhci_hcd  
usb 1-3: Device not responding to setup address.  
usb 1-3: Device not accepting address 14, error -71  
usb usb1-port3: unable to enumerate USB device  
usbcpre: registered new interface driver usbhid  
usbhid: USB HID core driver  
input: Logitech Logitech USB Keyboard as /device/pci0000:00/0000:0...../input13  
hid-generic 000...: input.hidraw0: USB HID v1.10 Keyboard [Logitech Logitech USB Keyboard] on usb-000..../input0  
input: Logitech Logitech USB Keyboard as /device/.../input14  
hid-generic 000...: input.hidraw1: USB HID v1.10 Device [Logitech Logitech USB Keyboard] on usb-000..../input1  

Furthermore I was able to boot the Debian Live-DVD (without UEFI) just fine.

Update 3: I was only able to boot the Live-DVD fine at the first 2 tries. Later I had to boot about 30 times(!) to get it working once more.
It either booted my SSD even though I had selected the CD manually via the boot-settings at startup or via boot-override in the bios options and even though I had selected CD, UEFI CD and USB CD as first boot entries and/or said:

error: no such partition.
Entering rescue mode...
grub rescue> _

However another Live-CD kept working at first try no matter what I did. And with that one I used GParted to delete all partitions (I also tried creating partitions but that didn't help either). After the first 2 tries I built in my NVidea graphics card and connected my WLAN stick. I did not configure WLAN and removed both after it didn't work anymore.

I tried installing Debian from the Live-DVD where the installer said:

 Installation of GRUB failed
 Packet >grub-pc< could not be installed to /target/. Without the GRUB-bootloader the system can't boot.

Upon which I researched it and, as adviced somewhere, connected to the Internet. The installation then went through without this error. But I still couldn't boot up Debian from my SSD, as it said:

usb 1-3: device descriptor read/64, error -71  
usb usb1-port4: unable to enumerate USB device  
usb 1-3: device descriptor read/64, error -71  
usb 1-3: device descriptor read/64, error -71  
usb 1-3: device descriptor read/64, error -71  
usb 1-3: device descriptor read/64, error -71  
usb 1-3: Device not accepting address 14, error -71  
usb 1-3: Device not accepting address 15, error -71  
usb usb1-port3: unable to enumerate USB device  

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules: ls /dev)
ALERT! /dev/mapper/name--vg-root does not exist. Dropping to a shell!
modprobe: module ehci-orion not found in modules.dep

BusyBox v1.22.1 (Debian 1:1.22.0-9+deb8u1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty: job control turned off
(initramfs)
(initramfs)

Maybe this is relevant. Any ideas on what the cause might be or what to try?

Edit: It now works with Debian 9.0 (released after I posted this question).

closed as primarily opinion-based by ilkkachu, EightBitTony, Rui F Ribeiro, phk, Kusalananda Jun 2 '17 at 15:51

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise. If this question can be reworded to fit the rules in the help center, please edit the question.

  • From the question you linked it looks like the problem is not UEFI, but possibly driver problems, together with full-disk encryption. To find out if it works or not, put e.g. a live distribution on a USB stick, boot from it and see what happens. If it really UEFI is the problem, booting with legacy BIOS is completely fine. It's also enough to encrypt your data (not system) using Linux only, no need to do this in UEFI. – dirkt May 31 '17 at 7:11
  • @dirkt After my latest test (see my update above) it indeed seems like the problem isn't UEFI as described. It's not enough to encrypt my data. Which drivers could that be? I'm only using onboard graphics. So the mainboard is still the cause isn't it? – mYnDstrEAm Jun 1 '17 at 7:07
  • 1
    The way to debug problems is to make things simpler, and test. While testing, you look at the system messages and figure out what goes wrong. Wild guesses won't help. The only error message I have seen in your other question is a USB read failure. So the question is: (1) which USB fails to read? (2) Can you test without this device? (3) When you boot, what are the messages? If you can get to a textual login prompt, the commands to answer these questions are lsusb to show your USB devices, and dmesg to see the system message log after boot. – dirkt Jun 1 '17 at 7:16
  • Thanks, that's helpful. The only USB are keyboard & mouse which worked but I'll try. – mYnDstrEAm Jun 1 '17 at 7:27
  • @dirkt: I tried that now. Please see my update above. – mYnDstrEAm Jun 2 '17 at 9:20
1

Ok, let's try to sort things out. It's a bit difficult to figure out what's happening exactly, because (quite understandably, as a newbie) the information you give is a bit partial.

From what I understand so far it seems that:

1) You are able to boot, both from your SDD, and with a Live DVD.
2) There are USB problems when booting from your SDD (but not from the Live DVD)
3) There are other problems like no graphics when booting from your SDD (but not from the Live DVD).

The lsusb output contains information about where every device is. E.g., for my system:

$ lsusb
...
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 005: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
...

That says I have several USB busses, and bus 3 has a USB 2.0 hub, and my mouse is on this bus. So I'd expect error messages for this mouse to use something like usb 3-.... You can also get more details in tree format:

$ lsusb -t
...
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 1: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
            |__ Port 1: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M

So my mouse (device 5) is behind a hub (which happens to be in my monitor) at the root hub in my PC. So in dmesg, the mouse would show up as usb 3-1.1.1 (bus 3, then always port 1). And in fact it does:

[    3.129137] usb 3-1.1.1: New USB device found, idVendor=046d, idProduct=c00c
[    3.129217] usb 3-1.1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.129291] usb 3-1.1.1: Product: USB Mouse
[    3.129348] usb 3-1.1.1: Manufacturer: Logitech

So that's how you can identify your usb 1-3 device. Let's assume it's the mouse.

Possible reasons are: it doesn't get enough power, there's something wrong with the hardware, there's something wrong with the drivers.

So what you try is: (a) plug it in a different hub, see if you get the same message (no need to reboot, just look at dmesg). (b) Look at dmesg to see if there's some error. (c) Try the Live DVD, which might have different drivers, and see if it happens there, too.

Here's how you handle text output on the command line:

The Linux commandline is nice, because you can take all output from a command and so something with it. For example,

$ dmesg | less

will allow you to inspect the complete output with a pager called less,

$ dmesg > /tmp/dmesg.log

will save the output in a file, which you can then inspect with

$ less /tmp/dmesg.log

etc. You can also save the output on a USB stick with FAT, so you can put it e.g. in a pastebin, as your browser doesn't work yet.

Finally, the graphics environment. Does it work when booting from the Live DVD? If yes, can you install directly from the Live DVD, using the same set of kernels and drivers is it does? That should fix the problem. If not, it again means inspecting dmesg and finding the error (wrong or missing driver).

  • Thanks you! I still have the same problems when disconnecting the mouse (and keyboard until it's needed) before booting from the SSD while they both work without problems for the Live-DVD. Haven't checked if I get slightly different error messages yet. The graphics environment works from the DVD and I'll try installing it from there today (note that the DVD only works with legacy BIOS and not with UEFI which I intended to use earlier). – mYnDstrEAm Jun 2 '17 at 13:38
  • 1
    Definitely check dmesg from both the Live DVD and from the SSD directly after boot, and look for differences. Once you've installed your Linux system, and verified it works, you can still switch from legacy BIOS to UEFI. If you use a separate partition for /home, you can also encrypt this later on (but do that before you put important files onto it). – dirkt Jun 2 '17 at 15:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.