0

Months ago I tried to install Zorin OS but it failed. Now, I have a removable device located at /dev/sda2 with its name.

enter image description here

It is very weird because when I try to mount it, there is an error saying

Failed to mount "Zorin OS 12 Core"

Error mounting /dev/sda2 at /media/gabriel/Zorin OS 12 Core: Command-line `mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500" "/dev/sda2" "/media/gabriel/Zorin OS 12 Core"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda2,missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

Also, I've installed Debian. I erased all the partitions and made it configure them by itself, but this device insists on appearing. I just want to remove it.

This is the result of fdisk -l /dev/sda

enter image description here

And this is the output of file -s /dev/sda2:

/dev/sda2: DOS/MBR boot sector; partition 1 : ID=0x82, start-CHS (0x3ff,254,63), end-CHS (0x3ff,254,63), startsector 2, 24700928 sectors

Also, the output of cat /etc/fstab:

#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=00cb11e7-293f-491e-95d0-e346eacacbea /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=45e64e53-feac-48e4-afd1-3354411e91dc none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
  • 2
    You say /dev/sdb2 first, but the failed mount command says /dev/sda2. You should use lsblk and/or fdisk to check and maybe add the output to the question to clarify things. Also, why do you think the fs type is iso9660? – NickD May 30 '17 at 2:33
  • There is no /dev/sdb at all. – gamofe May 30 '17 at 2:59
  • 1
    If that /dev/sdb2 on line 2 of your question is a typo, then edit the question and fix it. – NickD May 30 '17 at 3:05
  • Yes, sorry. It is not /dev/sdb2` but sda2. – gamofe May 30 '17 at 3:06
  • I updated my question with outputs of commands suggested below. – gamofe May 30 '17 at 3:14
1

As you can see from the fdisk output, /dev/sda2 is an "extended partition" (a workaround that allows you to have more than 4 partitions with the MBR partition scheme). This partition is completely used as swap (/dev/sda5). This doesn't make a lot of sense: If you want to keep it that way, you could have just used /dev/sda2 as swap partition, no need to use an extended partition if you don't need more than 2 partitions, anyway.

But it's not broken or messed up. No need to reinstall anything.

The error message says that for some reason, you try to mount the extended partition on /media/gabriel/Zorin OS 12 Core as an ISO image (a CD image). Now this makes no sense at all: An extended partition should never be mounted in the first place, and it also doesn't contain an ISO image.

Look at /etc/fstab to see if there's still an entry in there remaining from when you tried to install Zorin OS. Remove that entry, and all should be fine. Also decide what partitions you actually want on your harddisk, and maybe remove the extended partition, and use it as swap space directly.

  • Yes, it does not make the least sense. Even erasing all partitions and letting Debian crate by itself, it still exists. I updated my question with the output of cat /etc/fstab – gamofe May 30 '17 at 7:11
  • Possibly Debian just creates an extended partition by default these days. There's nothing wrong with that, it's just a bit less efficient if you don't need it. Your fstab looks good, how did you try to mount "Zorin OS 12 Core", and where does it show up? – dirkt May 30 '17 at 7:27
  • It shows up on the Desktop. I tried to mount it by simply clicking twice. I want to remove or rename it, I do not want with this name. – gamofe May 31 '17 at 7:51
  • Which Desktop is that? Gnome? Possibly some leftover in the Gnome configuration (or whatever desktop it is). I use neither Gnome nor KDE, so I can't help you with that. – dirkt May 31 '17 at 11:58
  • It is XFCE, @dirkt – gamofe Jun 1 '17 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.