2

After installing the last MacOS Sierra update, I lost my camera on Facetime and Skype, and in web apps; the name of the camera to be selected simply stops appearing on those apps, it is as if I do not have a camera from their point of view.

I actually had this problem many times in the past, and often a reboot fixed it. However, I rebooted several times, and it did not solve the situation.

I also tried several solutions on forums, including killing the camera daemon without much success.

This issue keeps happening even after the upgrade to High Sierra in my 2013 Macbook Pro 13''. Interestingly enough, it does not happen with my new MacBook Pro 15''

What to do?

  • 1
    This question should have gone to apple.stackexchange.com as it's about macOS front-end applications. – Kusalananda May 18 '18 at 9:12
  • @Kusalananda (re)pluging a Unix device is not only about frond-end applications. This is an interaction with the hw and OS/X starting, with some models. You do not have the appropriate device created upon the system boot, as far as I remember. The lack of camera in web and system apps, or pretty much anywhere, is a symptom. – Rui F Ribeiro May 18 '18 at 11:15
  • Probably not the solution you are looking for, but I once solved a not working camera problem on my flatmate's MacBook Pro (I think it was a 2011 model) by installing manjaro on it. Just liked to mention it anyway... – dalanicolai May 24 at 10:03
1

The original replug didn't work for me.

It turns out on older macbook pro's the isight camera is named differently. I downloaded the original sources and modified them per the instructions found on the link below and the replug now works. Still have to run it after each reboot.

https://github.com/dskr99/mac_usb_eject/issues/1

Unfortunately, I faced a problem that replug_facetime didn't detect old camera type named "Built-in iSight" in my MacBook Pro Mid 2009.

I changed a pattern in file replug_facetime.cpp, line 116 to if (NULL != strstr(sFriendlyName, "Built-in iSight")) { and it worked for me after rebuilding.

| improve this answer | |
  • Hi, edited you answer with information from the link. if you come back to this, we usually have the policy of not giving answers consisting mainly of links. Links might die over time. Please see our FAQ. +1 – Rui F Ribeiro May 24 at 7:00
0

There are some known issues at least with the late 13'' model, and this quirk might (or not) be due to that.

I ended up finding a fix for a similar problem for people that have Parallels installed. This workaround works without having Parallels installed.

This is a widespread issue on macOS Sierra
By running this fix you are resetting the Facetime camera. You should apply this fix each time you want to use the Facetime camera

While I have VMWare Fusion, and not Parallels the fix worked for me in the real machine.

While Parallels KB insists on saying it is an interaction between their product and Sierra, I believe genuinely this is a MacOS bug.

So for solving this, I downloaded http://kb.parallels.com/Attachments/kcs-40680/replug_facetime.zip

and running it with the command:

sudo ~/Downloads/replug_facetime

made the Camera work again.

From the binary itself:

replugging the Facetime camera device...

Failed to create PluginInterface:

The fix has to be applied again after each reboot (when the camera does not start working). A permanent workaround is to put it in the startup sequence, it does not harm trying to (re)plug the device if it is already connected.

PS replug_facetime source code can be downloaded from here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.