1

I use Ubuntu 14.04. And I am trying t install dpkg-dev which requires some dependency files.

bin$ sudo apt-get install dpkg-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dpkg-dev : Depends: libdpkg-perl (= 1.17.5ubuntu5) but 1.17.5ubuntu5.6 is to be installed
            Recommends: build-essential but it is not going to be installed
            Recommends: fakeroot
            Recommends: libalgorithm-merge-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After which, I am Doing the below., which was recommended to install all the dependencies, the previous installation required.

bin$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libsdl-image1.2 libtar0 libva-x11-1 libxcb-composite0 libxcb-xv0
  vlc-plugin-notify vlc-plugin-pulse
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

which fails to do the job. Pls recommend a way to overcome this hurdle. Thanks in advance.

0

1 Answer 1

3
  1. Update package list, see if that fixes it.

  2. Use another tool like aptitude to manually pick versions, and resolve the conflict. The UI needs some time to get used to, but it's great to rescue screwed-up dependencies.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .