1

i'm frustating with my new laptop, Wifi works well and can detect wifi signal around it.

The problem is when i connected to my wifi just 1-2 minutes the wifi will be disconnecting and when i try to reconnect, wifi doesn't to connect.

After restarting the laptop, all work as usual again, I can connect and again only 1-2 minutes wifi will be disconnected.

I have tried kali linux, ubuntu, opensuse it still same. Now, my laptop is using Elementary OS and Realtek RTL8723BE PCIe Wireless Network Adapter

test@test:~$ inxi -Fxz
System:    Host: hmvoc9 Kernel: 4.8.0-52-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Gnome  (Gtk 3.18.9-1ubuntu3.3) Distro: elementary 0.4.1 loki
Machine:   System: LENOVO (portable) product: 80KY v: Lenovo G40-80
           Mobo: LENOVO model: Lenovo G40-80 v: NO DPK Bios: LENOVO v: B0CN80WW date: 05/18/2015
CPU:       Dual core Intel Core i3-4030U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7581
           clock speeds: max: 1800 MHz 1: 799 MHz 2: 799 MHz 3: 809 MHz 4: 830 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]
           bus-ID: 04:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.8.0-52-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 5000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.4% used) ID-1: /dev/sda model: WDC_WD5000LPCX size: 500.1GB
Partition: ID-1: / size: 23G used: 3.7G (18%) fs: ext4 dev: /dev/sda9
           ID-2: /home size: 74G used: 129M (1%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: N/A gpu: 42.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 199 Uptime: 19 min Memory: 1043.6/3871.3MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35 

iwconfig

test@test:~$ iwconfig
lo        no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on

enp0s20u3  no wireless extensions.

enp2s0    no wireless extensions.

Note: When i check my info, I'm using mobile connection with usb tether.

i'm try to search on google for my solution. I have installed rtlwifi_new and follow the step by step in google but still can't connect.

  • How strong is the wifi signal? – saga May 28 '17 at 6:42
  • my wifi signal is good bro @saga – Rofi Fathurrohman May 28 '17 at 6:45
  • was it good before you installed rtlwifi_new? – saga May 28 '17 at 6:58
  • my wifi signal is good before and after installed rtlwifi_new bro, and wifi still disconected 1-2 minutes connected before and after installing rtlwifi_new @saga – Rofi Fathurrohman May 28 '17 at 7:00
  • 1
    Realteak is junk made by Chineses at cents a pop...buy a stick from another brand. This is an hw problem, please do not spam us with the same question ad naseaum. Any amount of Linux directives wont fix a firmware/hw problem. unix.stackexchange.com/questions/252210/… – Rui F Ribeiro May 28 '17 at 7:48
1

Create a /etc/modprobe.d/rtl8723be.conf with the following contents:

options rtl8723be fwlps=0

the problem is explained on the archlinux-wiki:

Some users may encounter errors with powersave on this card. This is shown with occasional disconnects that are not recognized by high level network managers (netctl, NetworkManager). This error can be confirmed by running dmesg -w or journalctl -f and looking for output related to powersave and the rtl8723ae/rtl8723be module. If you are having this issue, use the fwlps=0 kernel option, which should prevent the WiFi card from automatically sleeping and halting connection.

/etc/modprobe.d/rtl8723be.conf

options rtl8723be fwlps=0

  • 1
    All realtek cards have power management bugs in hw and firmware , and the power management has to be disabled. Performance is also subpar no matter what you do – Rui F Ribeiro May 28 '17 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.