2

I have triple boot System(Ubuntu,Kali,Win7) and I mostly use Kali linux(4.6.0-kali1-amd64). After each 3 or 4 successful boots i get this error ->

    fsck.ext4: Superblock checksum does not match superblock while trying 
    to access /dev/sda7
    /dev/sda7:
    Superblock cannot be read may be an invalid ext2 filesystem. 
    If yor device really formatted with ext fil system then 

Superblock may have been currupted try running e2fsck

    e2fsck -b 8193 <device>

    fsck exited with status code 8

And after this as root cannot be mounted due to this error & enters into (initramfs) Console where i have to run fsck command.

The Temporary Solution Worked for me is:

I simply ran

    e2fsck -b "Magick Number" /dev/sda7 
     OR
    fsck /dev/sda7

and then rebooting kali worked perfectly but problem occurs again after some boots(as mentioned before). No such problem for Ubuntu. So how do I fix it? And Yes.. Does time affects on super block? Because there is incorrect time in my Kali but not in Ubuntu and Windows

NOTE: e2fsck & fsck didn,t worked for me

fdisk Output:

$fdisk /dev/sda

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x851b9aac

Device     Boot      Start        End   Sectors   Size Id Type
/dev/sda1  *          2048     206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2           206848  976762879 976556032 465.7G  7 HPFS/NTFS/exFAT
/dev/sda3       1175027710 1953521663 778493954 371.2G  f W95 Ext'd (LBA)
/dev/sda4        976762880 1175025663 198262784  94.6G 83 Linux
/dev/sda5       1396195328 1911578623 515383296 245.8G  7 HPFS/NTFS/exFAT
/dev/sda6       1911580672 1953521663  41940992    20G 83 Linux
/dev/sda7       1175027712 1387147263 212119552 101.2G 83 Linux
/dev/sda8       1387149312 1396193279   9043968   4.3G 82 Linux swap / Solaris

Partition 3 does not start on physical sector boundary.
Partition table entries are not in disk order.
  • Ideas: Check SMART data (smartctl) to see if your harddisk is failing. Do a memorytest to see if your RAM has problems. Check if you have some application that for some reason uses the partition directly, and can corrupt the superblock. ext4 is mature enough that I don't think it's a bug causing the superblock corruption, but who knows ... – dirkt May 28 '17 at 9:19
  • 1
    It could be that your partitions are overlapping. Run fdisk -l /dev/sda and look at its output. Nothing should overlap (except for the extended partition, if any). – Mark Plotnick May 28 '17 at 19:14
  • @MarkPlotnick I've added the output. And it seems to be OK. – Dirty_Programmer May 29 '17 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.