5

I've just encountered an annoying visual problem - there is a pretty thick bottom and thin right border in xfce4-terminal. I guess I didn't notice it before because I was using visually non-enchanted editors before. The problem can be clearly seen when, for example, using vim themes. It is not so oblivious when using out-of-the-box nano but the border / margin is still there.

Is there a way to remove the border?

A related screenshot (teal bottom and right border)

enter image description here

  • 1
    Not sure about the bottom, but the right side appears to be a scrollbar, which can be disabled in the terminal preferences – Fox May 29 '17 at 16:32
1

Had the same issue just today. Happens only when I maximize the terminal window. "Solved" it by just setting my terminal background color the same as the one from my vim theme...

See Reddit Thread:

Vim can only paint the background by printing characters which is why it can't change the color of the left over space - it's too short to fit any characters.

I still dont get why it only happens in fullscreen and not like every 9 of 10 pixels, though.

I'm stupid; This is because the terminal app does not resize per pixel but per character. So of course manual resizing never brings a border. But this also means, you could simply fix this problem by choosing a bigger/smaller font in your terminal app, where your screen resolution is a real multiple of the character width.

Also:

Try this in your vimrc after your theme is loaded, works for jellybean at least:

hi Normal ctermbg=none

Might make some other trouble, but you could give it a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.