1

setting up my first server and ran into a problem while installing webmin.

I am following this tutorial to help me out (see 8:51): link

I do the following:

wget http://wwww.webmin.com/download/rpm/webmin-current.rpm

rpm -U webmin-current.rpm

on the second line i get

error: failed dependencies: 
      perl(Encode::Detect) is needed by webmin-1.840-1.noarch
0

Use yum or dnf to resolve dependencies instead of using rpm directly. If you do the following it will automatically install the perl RPM you need:

sudo dnf install webmin-current.rpm

Or if you really want to install via rpm directly, this will install the rpm you need:

sudo dnf install 'perl(Encode::Detect)'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.