6

I've installed FreeBSD 11.0 on my MacBook Air (13-inch, Early 2015). However, when configuring the network, no list of network interfaces is shown to me. Instead, I was brought to the Choose IPv4 Networking screen.

Currently I have Internet access through an Ethernet cable, but I want to configure the internal network card as soon as possible, for carrying around an Ethernet cable seems pretty stupid.

Here is some relevant information (retrieved when the Ethernet cable is plugged in):

ifconfig

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    inet 127.0.0.1 netmask 0xff000000 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo 
ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=8000b<RXCSUM,TXCSUM,VLAN_MTU,LINKSTATE>
    ether 00:23:57:1c:88:55
    inet6 fe80::223:57ff:fe1c:8855%ue0 prefixlen 64 scopeid 0x2 
    inet 192.168.0.107 netmask 0xffffff00 broadcast 192.168.0.255 
    nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active

pciconf -lv

hostb0@pci0:0:0:0:  class=0x060000 card=0x011b106b chip=0x16048086 rev=0x09 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Broadwell-U Host Bridge -OPI'
    class      = bridge
    subclass   = HOST-PCI
vgapci0@pci0:0:2:0: class=0x030000 card=0x011b106b chip=0x16268086 rev=0x09 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'HD Graphics 6000'
    class      = display
    subclass   = VGA
hdac0@pci0:0:3:0:   class=0x040300 card=0x011b106b chip=0x160c8086 rev=0x09 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Broadwell-U Audio Controller'
    class      = multimedia
    subclass   = HDA
xhci0@pci0:0:20:0:  class=0x0c0330 card=0x72708086 chip=0x9cb18086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP USB xHCI Controller'
    class      = serial bus
    subclass   = USB
none0@pci0:0:22:0:  class=0x078000 card=0x72708086 chip=0x9cba8086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP MEI Controller'
    class      = simple comms
hdac1@pci0:0:27:0:  class=0x040300 card=0x72708086 chip=0x9ca08086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP High Definition Audio Controller'
    class      = multimedia
    subclass   = HDA
pcib1@pci0:0:28:0:  class=0x060400 card=0x72708086 chip=0x9c908086 rev=0xe3 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib2@pci0:0:28:1:  class=0x060400 card=0x72708086 chip=0x9c928086 rev=0xe3 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:28:2:  class=0x060400 card=0x72708086 chip=0x9c948086 rev=0xe3 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib4@pci0:0:28:4:  class=0x060400 card=0x72708086 chip=0x9c988086 rev=0xe3 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib5@pci0:0:28:5:  class=0x060400 card=0x72708086 chip=0x9c9a8086 rev=0xe3 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
isab0@pci0:0:31:0:  class=0x060100 card=0x72708086 chip=0x9cc38086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP LPC Controller'
    class      = bridge
    subclass   = PCI-ISA
none1@pci0:0:31:3:  class=0x0c0500 card=0x72708086 chip=0x9ca28086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP SMBus Controller'
    class      = serial bus
    subclass   = SMBus
none2@pci0:0:31:6:  class=0x118000 card=0x72708086 chip=0x9ca48086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wildcat Point-LP Thermal Management Controller'
    class      = dasp
none3@pci0:2:0:0:   class=0x048000 card=0x157014e4 chip=0x157014e4 rev=0x00 hdr=0x00
    vendor     = 'Broadcom Limited'
    device     = '720p FaceTime HD Camera'
    class      = multimedia
none4@pci0:3:0:0:   class=0x028000 card=0x0117106b chip=0x43a014e4 rev=0x03 hdr=0x00
    vendor     = 'Broadcom Limited'
    device     = 'BCM4360 802.11ac Wireless Network Adapter'
    class      = network
ahci0@pci0:4:0:0:   class=0x010601 card=0xa801144d chip=0xa801144d rev=0x01 hdr=0x00
    vendor     = 'Samsung Electronics Co Ltd'
    class      = mass storage
    subclass   = SATA

dmesg

Copyright (c) 1992-2016 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 01:43:23 UTC 2016
    root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0)
VT(efifb): resolution 1440x900
CPU: Intel(R) Core(TM) i5-5250U CPU @ 1.60GHz (1600.03-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x306d4  Family=0x6  Model=0x3d  Stepping=4
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x7ffafbbf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,SDBG,FMA,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
  AMD Features=0x2c100800<SYSCALL,NX,Page1GB,RDTSCP,LM>
  AMD Features2=0x121<LAHF,ABM,Prefetch>
  Structured Extended Features=0x21c27ab<FSGSBASE,TSCADJ,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,NFPUSG,RDSEED,ADX,SMAP,PROCTRACE>
  XSAVE Features=0x1<XSAVEOPT>
  VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
  TSC: P-state invariant, performance statistics
real memory  = 4294967296 (4096 MB)
avail memory = 3969339392 (3785 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <APPLE  Apple00>
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s) x 2 hardware threads
random: unblocking device.
ioapic0 <Version 2.0> irqs 0-39 on motherboard
random: entropy device external interface
kbd0 at kbdmux0
netmap: loaded module
module_register_init: MOD_LOAD (vesa, 0xffffffff8101c950, 0) error 19
random: registering fast source Intel Secure Key RNG
random: fast provider: "Intel Secure Key RNG"
cryptosoft0: <software crypto> on motherboard
acpi0: <APPLE Apple00> on motherboard
acpi_ec0: <Embedded Controller: GPE 0x4e, ECDT> port 0x62,0x66 on acpi0
acpi0: Power Button (fixed)
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed03fff irq 0,8 on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 550
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
Event timer "HPET3" frequency 14318180 Hz quality 440
Event timer "HPET4" frequency 14318180 Hz quality 440
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x77 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1808-0x180b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0x3000-0x303f mem 0xc0000000-0xc0ffffff,0xb0000000-0xbfffffff at device 2.0 on pci0
vgapci0: Boot video device
hdac0: <Intel Broadwell HDA Controller> mem 0xc1610000-0xc1613fff at device 3.0 on pci0
xhci0: <Broadwell Integrated PCH-LP chipset USB 3.0 controller> mem 0xc1600000-0xc160ffff at device 20.0 on pci0
xhci0: 32 bytes context size, 64-bit DMA
xhci0: Port routing mask set to 0xffffffff
usbus0 on xhci0
pci0: <simple comms> at device 22.0 (no driver attached)
hdac1: <Intel Broadwell HDA Controller> mem 0xc1614000-0xc1617fff at device 27.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <multimedia> at device 0.0 (no driver attached)
pcib3: <ACPI PCI-PCI bridge> at device 28.2 on pci0
pci3: <ACPI PCI bus> on pcib3
pci3: <network> at device 0.0 (no driver attached)
pcib4: <ACPI PCI-PCI bridge> at device 28.4 on pci0
pci4: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 28.5 on pci0
pci5: <ACPI PCI bus> on pcib5
ahci0: <AHCI SATA controller> mem 0xc1300000-0xc1301fff at device 0.0 on pci5
ahci0: AHCI v1.30 with 1 6Gbps ports, Port Multiplier not supported
ahcich0: <AHCI channel> at channel 0 on ahci0
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
ppc0: cannot reserve I/O port range
uart0: <8250 or 16450 or compatible> at port 0x3f8 irq 4 flags 0x10 on isa0
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3
Timecounters tick every 1.000 msec
nvme cam probe device init
hdacc0: <Intel Broadwell HDA CODEC> at cad 0 on hdac0
hdaa0: <Intel Broadwell Audio Function Group> at nid 1 on hdacc0
pcm0: <Intel Broadwell (HDMI/DP 8ch)> at nid 3 on hdaa0
hdacc1: <Cirrus Logic (0x4208) HDA CODEC> at cad 0 on hdac1
hdaa1: <Cirrus Logic (0x4208) Audio Function Group> at nid 1 on hdacc1
pcm1: <Cirrus Logic (0x4208) (Analog)> at nid 18 and 24 on hdaa1
pcm2: <Cirrus Logic (0x4208) (Analog Headphones)> at nid 16 on hdaa1
usbus0: 5.0Gbps Super Speed USB v3.0
ugen0.1: <0x8086> at usbus0
uhub0: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
ada0: <APPLE SSD SM0128G BXW1JA0Q> ATA8-ACS SATA 3.x device
ada0: Serial Number S1W1NYBG400251
ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 115712MB (236978176 512 byte sectors)
SMP: AP CPU #1 Launched!
SMP: AP CPU #2 Launched!
SMP: AP CPU #3 Launched!
Timecounter "TSC" frequency 1600032780 Hz quality 1000
Trying to mount root from ufs:/dev/ada0p5 [rw]...
uhub0: 15 ports with 15 removable, self powered
ugen0.2: <VIA Labs, Inc.> at usbus0
uhub1: <VIA Labs, Inc. USB2.0 Hub, class 9/0, rev 2.10/91.00, addr 1> on usbus0
uhub1: 4 ports with 4 removable, self powered
ugen0.3: <Apple Inc.> at usbus0
uhub2: <Apple Inc. BRCM20702 Hub, class 9/0, rev 2.00/1.00, addr 2> on usbus0
uhub2: 3 ports with 0 removable, self powered
ugen0.4: <vendor 0x05ac> at usbus0
ukbd0: <vendor 0x05ac product 0x820a, class 0/0, rev 2.00/1.00, addr 3> on usbus0
kbd1 at ukbd0
ugen0.5: <vendor 0x05ac> at usbus0
ugen0.6: <Apple Inc.> at usbus0
ugen0.7: <Apple Inc.> at usbus0
ukbd1: <Keyboard  Boot> on usbus0
kbd2 at ukbd1
wsp0: <Trackpad  Boot> on usbus0
ugen0.8: <VIA Labs, Inc.> at usbus0
uhub3: <VIA Labs, Inc. USB3.0 Hub, class 9/0, rev 3.00/91.01, addr 7> on usbus0
uhub3: 4 ports with 4 removable, self powered
ugen0.9: <ASIX Elec. Corp.> at usbus0
ugen0.10: <Apple> at usbus0
umass0: <Apple Card Reader, class 0/0, rev 3.00/8.20, addr 9> on usbus0
umass0:  SCSI over Bulk-Only; quirks = 0x4000
umass0:1:0: Attached to scbus1
ums0: <vendor 0x05ac product 0x820b, class 0/0, rev 2.00/1.00, addr 4> on usbus0
(probe0:umass-sim0:0:0:0): REPORT LUNS. CDB: a0 00 00 00 00 00 00 00 00 10 00 00 
(probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(probe0:umass-sim0:0:0:0): SCSI status: Check Condition
(probe0:umass-sim0:0:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
(probe0:umass-sim0:0:0:0): Error 6, Unretryable error
ums0: 3 buttons and [XY] coordinates ID=2
ubt0: <Apple Inc. Bluetooth USB Host Controller, rev 2.00/1.37, addr 5> on usbus0
axge0: <NetworkInterface> on usbus0
da0 at umass-sim0 bus 0 scbus1 target 0 lun 0
da0: <APPLE SD Card Reader 3.00> Removable Direct Access SPC-4 SCSI device
da0: Serial Number 000000000820
da0: 400.000MB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present
da0: quirks=0x2<NO_6_BYTE>
WARNING: attempt to domain_add(bluetooth) after domainfinalize()
WARNING: attempt to domain_add(netgraph) after domainfinalize()
ugen0.4: <vendor 0x05ac> at usbus0 (disconnected)
ukbd0: at uhub2, port 1, addr 3 (disconnected)
ugen0.5: <vendor 0x05ac> at usbus0 (disconnected)
ums0: at uhub2, port 2, addr 4 (disconnected)
miibus0: <MII bus> on axge0
rgephy0: <RTL8169S/8110S/8211 1000BASE-T media interface> PHY 3 on miibus0
rgephy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
ue0: <USB Ethernet> on axge0
ue0: Ethernet address: 00:23:57:1c:88:55
ue0: link state changed to DOWN
ue0: link state changed to UP
ugen0.4: <vendor 0x090c> at usbus0
umass1: <vendor 0x090c USB DISK, class 0/0, rev 2.00/11.00, addr 10> on usbus0
umass1:  SCSI over Bulk-Only; quirks = 0x4000
umass1:2:1: Attached to scbus2
da1 at umass-sim1 bus 1 scbus2 target 0 lun 0
da1: < USB DISK 1100> Removable Direct Access SCSI device
da1: 40.000MB/s transfers
da1: 7681MB (15730688 512 byte sectors)
da1: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>

arp -an

? (192.168.0.107) at 00:23:57:1c:88:55 on ue0 permanent [ethernet]
? (192.168.0.1) at 54:b8:0a:0c:bf:58 on ue0 expires in 993 seconds [ethernet]

netstat -r

Routing tables

Internet:
Destination        Gateway            Flags     Netif Expire
default            192.168.0.1        UGS         ue0
localhost          link#1             UH          lo0
192.168.0.0/24     link#2             U           ue0
192.168.0.107      link#2             UHS         lo0

Internet6:
Destination        Gateway            Flags     Netif Expire
::/96              localhost          UGRS        lo0
localhost          link#1             UH          lo0
::ffff:0.0.0.0/96  localhost          UGRS        lo0
fe80::/10          localhost          UGRS        lo0
fe80::%lo0/64      link#1             U           lo0
fe80::1%lo0        link#1             UHS         lo0
fe80::%ue0/64      link#2             U           ue0
fe80::223:57ff:fe1 link#2             UHS         lo0
ff02::/16          localhost          UGRS        lo0

Also, when I ran either ifconfig wlan create wlandev bwi0 or ifconfig wlan create wlandev bwn0, it told me ifconfig: SIOCIFCREATE2: Device not configured.

I believe the Apple BCM4360 is supported by FreeBSD, and here is the evidence.

  • Are you installed the base system? what is the TP-link model? – GAD3R May 27 '17 at 13:39
  • 1
    @GAD3R OK, but I'm afraid I have no idea what does that mean... Also, here is what I see when I push in and pull out the external TP-LINK WLAN adapter. Hope it's relevant. – nalzok May 27 '17 at 14:39
  • 1
    @GAD3R Hey I'm installed FreeBSD on my MBA! Plus I can connect the computer to the Internet with Ethernet! Now I wonder how can I enable the built-in network card, i.e. lo0? – nalzok May 31 '17 at 17:20
  • 1
    @GAD3R I have a BCM4360 802.11ac Wireless Network Adapter – nalzok Jun 1 '17 at 7:43
  • 1
    Typical apple bs. I'm actually looking forward to having a reason to replace my MB Pro. So sick of their nonsense. – nenchev Jul 12 '18 at 17:45
3
+150

You might need to load all the following kernel modules:

sudo kldload if_bwn 
sudo kldload bwn_v4_ucode 
sudo kldload bwn_v4_lp_ucode

Do a research on if_bwn, bwn_v4_ucode and bwn_v4_lp_ucode, you might need slightly different kernel modules depending on your specific Broadcom wireless chip.

After you load required kernel modules, run:

sudo ifconfig wlan0 create wlandev bwn0
sudo ifconfig wlan0 up # Laptop WiFi LED light should turn on
sudo ifconfig wlan0 scan # You should see your wireless router SSID
sudo wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf 
sudo ifconfig wlan0 list sta 
sudo dhclient wlan0

I configured my laptop wireless chip, which is a BCM4311, on FreeBSD 10.3 one year ago, explained here, it may help you.

  • sudo kldload if_bwn executed successfully, but both sudo kldload bwn_v4_ucode and sudo kldload bwn_v4_lp_ucode returned an No such file or directory error…… – nalzok Jun 3 '17 at 11:37
  • @SunQingyao You might need to compile/install those missing kernel modules at /usr/ports/net/bwn-firmware-kmod or wherever they are inside /usr/ports/ – user3405291 Jun 3 '17 at 11:52
  • I tried running make install under that directory, but it told me ===> bwn-firmware-kmod-0.1.2 requires kernel source files in /usr/src *** Error code 1. I've checked /usr/src with ls -la, and it's an empty directory. What should I do now? – nalzok Jun 3 '17 at 12:00
  • 2
    @SunQingyao cd /usr/ports then sudo portsnap fetch extract and sudo portsnap fetch update – GAD3R Jun 4 '17 at 20:10
  • 1
    I've installed bwm-firmware-kmod-0.1.2, and loaded those modules, but it's still telling me "Device not configured"…… – nalzok Jun 9 '17 at 4:15
3

Unfortunately the BCM4360 is not yet supported, but it might be in the future. See http://landonf.org/code/freebsd/Broadcom_WiFi_Improvements.20180122.html for more information.

1

In the list you've linked, there's only one WiFi driver: bwn(4). You might want to do kldload bwn and see if it attaches.

  • After executing kldload bwn, both ifconfig wlan create wlandev bwi0 and ifconfig wlan create wlandev bwn0 still complaint ifconfig: SIOCIFCREATE2: Device not configured – nalzok Jun 2 '17 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.