2

/sbin/init does not exist

After installing Arch Linux I rebooted but now I am unable to complete the boot process. I end up at the screen above with this message

ERROR: Boot device mounted successfully, but /sbin/init does not exist. Bailing out, you are on your own. Good luck.

sh: can't access tty; job control turned off.

and a [rootfs ]# prompt.

I have checked and confirmed via a live disk that sbin exists as a symbolic link to /usr/bin. However I do not have the init file/folder in my /usr/bin directory. Where should I get the init file/folder? Did I miss a step during the installation? Is there anything I can do to correct this? Thanks.

  • On my archlinux system, /usr/bin/init is a symlink to /usr/lib/systemd/systemd, which is part of the systemd package. /usr/bin/init is itself part of the systemd-sysvcompat package (systemd is a dependency of this) and is part of the base group, which should have been installed as part of the install process – Benjamin May 26 '17 at 8:49
2

Following on from my comment, what I'd recommend you do to correct it is to reboot your system with the livecd (or whatever method you used to boot into the install environment) and redo these steps of the install process:

If it still isn't working after this, I'd suggest checking what filesystem is actually being mounted by the bootloader. Perhaps giving a list of what files are present in the /usr/bin directory would allow us to help you further.

0

I have spent half a day with this problem and eventually realized that the cause in my case was that I had set up /usr on a separate partition, and only the root partition was mounted at the point where the grub boot attempts to access /usr/bin/init.

I have solved the issue by moving the /usr file hierarchy onto the root partition.

richard

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.