0

I have a router flashed to run openwrt (BARRIER BREAKER (Bleeding Edge, r36234))

But opkg can't find packages.

According to the error messages and /etc/opkg.conf it seems to be trying to find them at : http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages which is clearly a deprecated address.

So where is the new repository? And can I point opkg at it simply by updating the address in the first line of /etc/opkg.conf?

(currently :

src/gz barrier_breaker http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages

)

1

What kind of device are you using? For generic ar71xx devices try to use the following sources (from the OpenWrt OPKG Techref page):

src/gz base https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/base
src/gz luci https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/luci
src/gz management https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/management
src/gz oldpackages https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/oldpackages
src/gz packages https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/packages
src/gz routing https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/routing
src/gz telephony https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/packages/telephony

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.